Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since updating to Firefox 10, when I select web pages in my drop down, they do not load automatically anymore

  • 3 replies
  • 7 have this problem
  • 62 views
  • Last reply by JFB21

more options

I used to be able to navigate to websites just by selecting them in the dropdown below the address bar, but since the upgrade to Firefox 10 when I select my desired URL from the drop down it does not load automatically anymore; Now I have to select it and then click the "go" arrow. How do I go back to the way it was?

Chosen solution

Try disabling AVG Safe Search from Tools > Add-ons (or waiting to see if they ship an update). This has happened before with similar extensions.

Read this answer in context 👍 1

All Replies (3)

more options

Firefox 10 should still load web pages automatically when you select them from the drop-down. There might be a bug or a configuration problem in your Firefox installation. Does this still happen if you restart Firefox in Troubleshoot Firefox issues using Safe Mode? (For instructions, see Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.)

more options

Chosen Solution

Try disabling AVG Safe Search from Tools > Add-ons (or waiting to see if they ship an update). This has happened before with similar extensions.

Modified by Cheng Wang

more options

mbrubeck, thanks for the advice, I followed the troubleshooting and, as Cww suggested, it was the AVG Safe Search extension add-on that was the culprit. I disabled it and everything works great. Thanks so much!!!!