Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am unable to have Firefox remember passwords. The "KEY" icon that is supposed to be on the left side of the location bar is not there. Windows Vista Ultimate, Firefox Version 9.0.1

  • 12 replies
  • 16 have this problem
  • 2177 views
  • Last reply by Mitya

more options

I need to have Firefox remember passwords. When I go to "HELP" to get instructions to do this I am told to click on the "KEY" icon on the left side of the location bar. There is no such icon. Windows Vista Ultimate, Firefox Version 9.0.1 I could use some help, thanks.

Chosen solution

Make sure that you do not run Firefox in permanent Private Browsing mode.

To see all History and Cookie settings, choose:

  • Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

See also:

Read this answer in context 👍 2

All Replies (12)

more options

Hey rookiejd,

Go to Tools >Options >Security and make sure that you have asked Firefox to remember passwords for websites.

There is a lot of useful information in this article about the Firefox Password Manager. It should answer any other questions you might have.

Hopefully this helps!

more options

Note

  • the key may only appear temporarily
  • you need to be logged out, so on this site use the link at the top edge that says sign out, you should then get the option to save the password as you log in again

The linked article from the post above explains how to view and check passwords.

Note also you may view passwords for this site if you

  1. click on the icon box at the end of the location bar that says mozilla.org
  2. another box then appears including an option for [more information] clicking that brings up options to view passwords
more options

Chosen Solution

Make sure that you do not run Firefox in permanent Private Browsing mode.

To see all History and Cookie settings, choose:

  • Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

See also:

more options

I have the same problem as the original poster: I have no "Remember Password" key and do not see a "Remember Password?" dialog. I am running Windows 7 Home Premium and Firefox 11. I do not have Private Browsing on. I have told Firefox to remember passwords. I have tried to apply the setting "Use custom settings for History" (Tools / Options / Privacy /. History) but it keeps reverting to "Remember History".

more options

That is OK. You see the "Remember History" choice if all history and cookie setting are the default. The "Use custom settings for History" selection only stays selected if at least one of the settings have been changed from the default.

Did you try Save mode?

  • Help > Restart with Add-ons Disabled
more options

Thanks, that explains why "Remember History" stays. Also I have now tried restarting with add-ons disabled (Safe mode) but this seems to make no difference to the missing password key etc.

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

Thanks again for the reply. I tried that and unfortunately it didn't help. (Maybe that's not surprising as I uninstalled and reinstalled Firefox and created a new profile only today.)

more options

Did you delete the Firefox program folder (C:\Program Files\Mozilla Firefox\) before (re)installing Firefox to make sure that security software or other software wasn't locking files in the Firefox program folder (C:\Program Files\Mozilla Firefox\)?

more options

No I didn't, so I've uninstalled Firefox again, deleted that folder (which contained a Default folder and a Plugins folder) and reinstalled it again. This time, when I signed in to the Firefox Community Support Forum, the "Remember password" dialog and key did appear, so to that extent it's working now. However, when I visited the websites I actually want Firefox to remember my passwords for, they didn't. Could this be because I have another browser (Opera) already set to remember my passwords for those sites?

more options

Website may be using autocomplete=off to prevent Firefox from saving and filling the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.

more options

Thanks again. I did try that and it doesn't seem to have worked -- still no dialog or key. I appreciate your efforts though.