Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Frequently "forgets" to load the css-styles. Restart needed!

  • 35 replies
  • 13 have this problem
  • 105 views
  • Last reply by PatGuano

more options

Mozilla Firefox 9.0.1 (and following), different from any other version of the Browser since 1.x, tends to forget loading the CSS-Styles when it displays arbitrary (X)HTML-pages.

While extensions like Firebug are still able to recognize what an element "should" look like, Firefox is not.

For the time being, restarting Firefox and just visiting the same URL once again, "helped"... No. This does *NOT* help, it is a major nuisance and a heavy bug.

Once in amnesia-mode, Firefox does not make a difference between the sites it has already visited (potentially cashed) and any new URL, that you visit. No style-definitions are honored, any more... until you restart the browser.

Modified by PatGuano

All Replies (20)

more options

And although it does not have any significance for the evaluation of the problem, here is the screen-shot of the error-console, once, that no styles are available. There is no error, when the styles are available for the very same page. Which of both errors' temporary absence allows Firefox to, -sometimes-, use the styles alright, I cannot say.

more options

And please, by all means ignore the fact, that something makes Firefox replace all 'ss' by the German character 'ß'. This happens in Thunderbird too and is not connected to the problem, that I am dealing.

more options

What is the distro you are using and exactly which version of firefox.

Obviously it should not do this, but I can not say I have seen it happen and am using Firefox 9 in linux at the moment myself.

The next thing to do is try to get a reproducible problem to report as a bug. With firefox in Troubleshoot Firefox issues using Safe Mode on the default themeg and with no plug-ins installed. If it does this on a reuglar basis can you also demonstrate it using a saved web page on a local drive.

The forum should get a lot of attention later today - USA daytime - (sumo day) you should be able to get expert help on the problem IF you can demonstrate how and when it happens.

Post a separeate question about the chractersbeing wrong,again you stand a better chance than normal of getting an answer Today. You may see the problem disapear in safemode &/or without firebug running.

more options

Thanks John. I have now created a second shortcut to start firefox routinely in safe mode and to collect experience this way. I will get back to the problem, once it occurs again and reproducibly on one and the same page.

The other problem with the strange characters is unrelated to Mozilla and must have its origin in my desktop-environment.

The current system is Ubuntu 11.10, with Fluxbox, a Rox-pinboard and fbpager. My wife uses a similar configuration with LXDE instead of Fluxbox and does not encounter the same misbehavior. This is really not related to Firefox, as far as I see, and I do not ask for a hint or solution in this forum.

TY.

more options

OK thanks for posting back.

If you do find what causes the problem you could always post into this thread again

more options

The characters being wrong can be caused by using a font that has ligatures and changes all double ss to a ß (same as compose ss does).

Modified by cor-el

more options

I present you three screen-shots:

1. A page, loaded from a local directory. This XHTML-page is currently work in progress, as it describes a small utility that I am about to publish. This is what happens, when Firefox does not load the CSS-styles.

2. The same page after having restarted Firefox.

3. The page of an online-dictionary, that I frequently use. This time, I got there by pushing the back-button, after the problem has occurred, first with the local file. I am no longer sure where I made the screen shot, but the english dictionary is here: http://dict.leo.org/ende?lang=de&lp=ende. Anyway you will see the difference... I guess.

There are some glitches in the css-code which I have identified. With the new evidence it becomes however clear, that they are not the core of the problem. For example, having altered a margin-setting, I ended with some strange line like margin-left: 0 0 1em 0; , the 'left' being now superfluous.

Screenshots are from Firefox 9.0.1 in safe-mode.

Modified by PatGuano

more options

Too simple.

@cor-el, of course, it was exactly that, an ADF-(OTF-) Font which made each occurence of 'ss' appear as 'ß'.

Lacking a nifty configuration-interface for Fluxbox, the possibility had completely escaped me. Retreating to "lxappearance", it took me 2 seconds to fix the font-setting.

"Jiehah".

more options

I observe now that the handling of CSS tends to be chaotic. In the meantime, it happened that a missing style was honored after my choleric hammering on the reload-button.

So, in case you are confronted with this behavior of Firefox, do not restrain yourself, just beat it senseless and it will finally obey.

In another case, only the @font-faces were ignored, while at the same time, a running Opera- and a running Epiphany-browser showed all in place and fine. Those font-face-declarations I haven't touched in a year or so, by the way.

I am the last to give advice to the developers of the Firefox-browser, but I may utter that sometimes less is more and be it to exercise my knowledge of English proverbs.

more options

Folks I have made a mistake in clicking the "solved" link above, where cor-el has presented the solution to an unrelated problem.

Ah. Found the "Undo" button. TY.

Modified by PatGuano

more options

Extensions can also cause such problems.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Thanks cor-el, but I do that already since John99 has given me the hint further up. My screen-shots are also taken from a save-mode session with Firefox.

I still start Firefox with an icon for the "Save Mode", but also wonder until when I have to do that. Even now, it is not possible to foresee which page will cause Firefox to misbehave and for which reason. It may be that I am the wrong person to analyze this and I am downright relieved that my other browsers have their own charms and still allow me to browse the web "fearlessly".

Modified by PatGuano

more options

If you do not see downloaded font then that may mean that Firefox doesn't do a final render after the font has been downloaded and extensions can cause such issues to happen.
Try to disable Torbutton and maybe any web developer related extensions like Web Web Developer and Firebug.

more options

What you are telling me now is that the message "All add-ans have been disabled by safe-mode" does not have any meaning at all.

More than "disable all" would be "uninstall some", I guess. But then I ask, what is safe-mode meant to do?

Modified by PatGuano

more options

That should normally be OK if you are in safe mode. Prefs may still be in the way. So you may try a new profile to see if it still happens there.

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

Okay, I will see how far I come with a new profile. Thanks.

more options

I am almost afraid to write this and do not want to close the thread prematurely, but since I have deactivated two extensions, I cannot claim to have encountered the "missing-style-problem" again. That is: in my default-profile with all the other extensions alive and kicking.

Something like "youtube high quality" extension (which I cannot remember to have installed in the first place) and the 'web-developer'-extension are gone. The latter, though having quite impressive functionality, has been scarcely useful to me, so I sacrificed it.

What influence the youtube-thing might have, I cannot say, but with the web-developer extension come some routines to analyze and potentially modify the DOM-tree of the currently displayed contents. It would be almost no mystery to me, if it turned out that an incompatibility between the extension and the browser has caused all the trouble.

Let us wait a little longer to be sure, though.

TY !

Modified by PatGuano

more options

Nope. With only Adblock and the dictionaries active, the problem PERSISTS !

Okay, I change the direction once again: This is a BUG in Firefox and it is unrelated to such extensions that you can easily do without. Firefox without Adblock and without the dictionaries is not any more an alternative to Opera or Epiphany and I would have to stop using it, in short.

Sorry folks. There is not 1 page, where I can securely reproduce the problem and not 1 profile which permitted me to do so. I see that in the meantime four other people are facing the same problem and venture to say that this is serious and not due to an error in handling the software or due to any extension misbehaving.

I cannot file a bug report. Someone else should do that.

X11; Linux i686 on x86_64; rv:10.0

Modified by PatGuano

more options

You may have Adblock Plus filters that are to generic if they prevent CSS from loading and working properly.

You can try the Adblock Plus forum.

more options

@cor-el: Thanks for trying (really) but that would have to be translated to: "prevent CSS from loading sometimes and sometimes not on a page where the behavior was different yesterday and will be different tomorrow", to be exact and given, that there were evidence that pointed me into this direction.

  1. 1
  2. 2