Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why Firefox doesn't ask to save a login

  • 1 reply
  • 1 has this problem
  • Last reply by cor-el

more options

Dear all, Windows-XP SP3 - I did upgrade Firefox from 3.6.x to 9.0.1 - every thing is working as before - except that Firefox doesn't ask to save a login any more! Even existing saved password are some times not working as usual. All setting are correct - no exception list active.

All Replies (1)

more options

Make sure that you do not run Firefox in permanent Private Browsing mode.

To see all History and Cookie settings, choose:

  • Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Websites may also be using autocomplete=off to prevent Firefox from saving the name and password.
You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.


Websites remembering you and automatically log you on is stored in a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Do not use Clear Recent History to clear the "Cookies" and the "Site Preferences"

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

See also: