Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF Reader plug-in not recognized by Firefox

  • No replies
  • 2 have this problem
  • 4 views
more options

Using the latest version of Firefox on a Mac running OS Snow Tiger.

In my browser prefs I have "Use Adobe Reader (default)" selected for all PDF documents presented to me online yet EVERY TIME I click on the PDF document, I get the error message: "It appears you don't have support to open PDFs in this web browser. A plugin is needed to display this content. Click here to install."

Yet which I follow that link, I get a message "No suitable plugins were found."

At the Mozilla side, PDF isn't even LISTED as an available plug-in!

Thus, I have to download the PDF file and open it with Adobe Reader.

This is truly a nuisance when I'm doing online research that involves a lot of reading of PDF documents.

Seems that I USED to be able to view PDF docs within my browser once upon a time ... what happened?

Using the latest version of Firefox on a Mac running OS Snow Tiger. In my browser prefs I have "Use Adobe Reader (default)" selected for all PDF documents presented to me online yet EVERY TIME I click on the PDF document, I get the error message: "It appears you don't have support to open PDFs in this web browser. A plugin is needed to display this content. Click here to install." Yet which I follow that link, I get a message "No suitable plugins were found." At the Mozilla side, PDF isn't even LISTED as an available plug-in! Thus, I have to download the PDF file and open it with Adobe Reader. This is truly a nuisance when I'm doing online research that involves a lot of reading of PDF documents. Seems that I USED to be able to view PDF docs within my browser once upon a time ... what happened?