X
Tap here to go to the mobile version of the site.

Support Forum

Firefox will freeze and become unresponsive when using google search from google website

Posted

Whenever I use google, which is often since it is my homepage, unless the thing I want to search for is within the first couple of auto-searches that pop up when I'm typing, the auto search will stop and if I press enter or click the search icon Firefox will freeze and I have to shut it down and try again. However, I have no problems when I try it with Firefox in Private browsing.

Whenever I use google, which is often since it is my homepage, unless the thing I want to search for is within the first couple of auto-searches that pop up when I'm typing, the auto search will stop and if I press enter or click the search icon Firefox will freeze and I have to shut it down and try again. However, I have no problems when I try it with Firefox in Private browsing.

Chosen solution

-> Clear Cookies & Cache

-> Clear the Network Cache

-> Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Check and tell if its working.

Read this answer in context 2

Additional System Details

Sites Affected

http://www.google.com

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • iTunes Detector Plug-in
  • Shockwave Flash 11.0 r1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • 4.0.60831.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Hasan 469 solutions 5600 answers

Chosen Solution

-> Clear Cookies & Cache

-> Clear the Network Cache

-> Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Check and tell if its working.

-> Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache -> [[How to clear the cache#w_clear-the-cache|Clear the Network Cache]] -> Reload web page(s) and bypass the cache. * Press and hold Shift and left-click the Reload button. * Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) * Press "Cmd + Shift + R" (MAC) Check and tell if its working.

Question owner

I tried this and there was no change, Firefox froze the next time I used google search.

I tried this and there was no change, Firefox froze the next time I used google search.
Hasan 469 solutions 5600 answers
-> [[Troubleshooting extensions and themes]] Check and tell if its working.
gregorys 1 solutions 15 answers

I have the same problem with Firefox 13.0.1 and latest Flash and Nvidia versions all is running on WinXP + SP3.

Firefox freezes always when searching images on Google without crash. It doesn't matter whether FF is in private or normal mode.

I tried to resolve it with reset to default settings, cleaned cache and new profile, but the problem remains.

When this happens I just try to scroll and my Dual Core CPU is already 100% overloaded. Page is loaded I can see some results from image search, but suddenly all becomes unresponsive. After waiting for a long time I can switch and still able to work with other windows with other tabs, but when I go back to the tab with Google image search results all start again 100% CPU overload and FF is unresponsive.

Currently I have only one option to resolve it by Disable new Google Images search style. It annoying but simply using this template for search queries http://www.google.com/images?q=Firefox&sout=1 where is necessary only to place search text on q=**** in the given url.

I have the same problem with Firefox 13.0.1 and latest Flash and Nvidia versions all is running on WinXP + SP3. Firefox freezes always when searching images on Google without crash. It doesn't matter whether FF is in private or normal mode. I tried to resolve it with reset to default settings, cleaned cache and new profile, but the problem remains. When this happens I just try to scroll and my Dual Core CPU is already 100% overloaded. Page is loaded I can see some results from image search, but suddenly all becomes unresponsive. After waiting for a long time I can switch and still able to work with other windows with other tabs, but when I go back to the tab with Google image search results all start again 100% CPU overload and FF is unresponsive. Currently I have only one option to resolve it by Disable new Google Images search style. It annoying but simply using this template for search queries http://www.google.com/images?q=Firefox&sout=1 where is necessary only to place search text on q=**** in the given url.

Modified by gregorys

cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:


You can also try a new profile by resetting Firefox.

Do a malware check with some malware scanning programs on the Windows computer.<br /> You need to scan with all programs because each program detects different malware.<br /> Make sure that you update each program to get the latest version of their databases before doing a scan.<br /><br /> *http://www.malwarebytes.org/mbam.php - Malwarebytes' Anti-Malware *http://www.superantispyware.com/ - SuperAntispyware *http://www.microsoft.com/security/scanner/en-us/default.aspx - Microsoft Safety Scanner *http://www.microsoft.com/windows/products/winfamily/defender/default.mspx - Windows Defender: Home Page *http://www.safer-networking.org/en/index.html - Spybot Search & Destroy You can also do a check for a rootkit infection with TDSSKiller. *http://support.kaspersky.com/viruses/solutions?qid=208280684 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked ---- You can also try a new profile by resetting Firefox. *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems
gregorys 1 solutions 15 answers

I haven't found malware. Firefox freezes on Google Image Search results when scrolling and CPU usage spikes. It's ok If I don't try to scroll.

I haven't found malware. Firefox freezes on Google Image Search results when scrolling and CPU usage spikes. It's ok If I don't try to scroll.

Modified by gregorys

gregorys 1 solutions 15 answers

Scrolling causes Firefox Freeze.

Scrolling causes Firefox Freeze.
gregorys 1 solutions 15 answers

I have also discovered in about:memory this:

Main Process

WARNING: the following values are negative or unreasonably large.
  explicit/network-memory-cache
  explicit/(6 tiny)
  explicit/(6 tiny)/heap-unclassified
  This indicates a defect in one or more memory reporters.  
  The invalid values are highlighted.

Explicit Allocations
210.53 MB (100.0%) -- explicit
+--4,096.00 MB ('''1945.54%''') -- network-memory-cache [?!]
+--124.37 MB (59.07%) -- js
   +---76.11 MB (36.15%) -- compartment([System Principal], 0x2e8e000)

+---4,037.98 MB ('''-1917.98%''') -- (6 tiny) [?!]
   +-------1.42 MB (00.67%) -- atom-table
   +-------0.93 MB (00.44%) -- xpti-working-set
   +-------0.21 MB (00.10%) ++ layout
   +-------0.16 MB (00.08%) -- cycle-collector
   +-------0.02 MB (00.01%) -- history-links-hashtable
   +---4,040.72 MB ('''-1919.28%''') -- heap-unclassified [?!]
I have also discovered in about:memory this:<br /> <br /> <pre><nowiki>Main Process WARNING: the following values are negative or unreasonably large. explicit/network-memory-cache explicit/(6 tiny) explicit/(6 tiny)/heap-unclassified This indicates a defect in one or more memory reporters. The invalid values are highlighted. Explicit Allocations 210.53 MB (100.0%) -- explicit +--4,096.00 MB ('''1945.54%''') -- network-memory-cache [?!] +--124.37 MB (59.07%) -- js +---76.11 MB (36.15%) -- compartment([System Principal], 0x2e8e000) +---4,037.98 MB ('''-1917.98%''') -- (6 tiny) [?!] +-------1.42 MB (00.67%) -- atom-table +-------0.93 MB (00.44%) -- xpti-working-set +-------0.21 MB (00.10%) ++ layout +-------0.16 MB (00.08%) -- cycle-collector +-------0.02 MB (00.01%) -- history-links-hashtable +---4,040.72 MB ('''-1919.28%''') -- heap-unclassified [?!]</nowiki></pre>

Modified by cor-el

Hasan 469 solutions 5600 answers
Perform the suggestions mentioned in the following articles: * [[Firefox uses too much memory (RAM) - How to fix]] * http://kb.mozillazine.org/Reducing_memory_usage_-_Firefox * [[Firefox uses too many CPU resources - How to fix]] * http://kb.mozillazine.org/Firefox_CPU_usage Check and tell if its working.
gregorys 1 solutions 15 answers

Nothing new, I stopped using Google to find images with FF13.

Nothing new, I stopped using Google to find images with FF13.

Modified by gregorys

gregorys 1 solutions 15 answers

On screen it looks like it is not scrolled but in fact it would have scrolled down. Ie It appears like GRAPHIC FREEZE.

Bug #1009201

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1009201

On screen it looks like it is not scrolled but in fact it would have scrolled down. Ie It appears like GRAPHIC FREEZE. Bug #1009201 https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1009201
gregorys 1 solutions 15 answers

How to Fix Scrolling Lag and freeze in Firefox 13 ?

How to Fix Scrolling Lag and freeze in Firefox 13 ?
Hasan 469 solutions 5600 answers

Start Firefox in Safe Mode to check if your add-ons/extensions or hardware acceleration are causing the problems, see this article:

Check and tell if its working normally while using Firefox in Safe Mode.

Start Firefox in Safe Mode to check if your add-ons/extensions or hardware acceleration are causing the problems, see this article: * [[Troubleshooting extensions and themes]] Check and tell if its working normally while using Firefox in Safe Mode.

Modified by Hasan