Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Vimeo videos do not display, YouTube & DailyMotion do

  • 27 replies
  • 4 have this problem
  • 605 views
  • Last reply by Randall

more options

Cannot see Vimeo videos in Firefox 9.0.1 on Windows 2000 (SP4). This is so whether they are on Vimeo's website or embedded elswhere.

Have cleared cache and restarted in Safe Mode with all add-ons dissabled.

First discovered the problem on the following page, but have looked at various pages on Vimeo's site.

http://wordpress.org/news/2012/01/help-stop-sopa-pipa/

Modified by Randall

All Replies (20)

more options

Hi,

Please check if this happens in Safe Mode.

more options

Did you try to test with a new Firefox profile? (Windows+R > firefox.exe -P)

more options

Yes it did as stated in my original post.

more options

"Did you try to test with a new Firefox profile? (Windows+R > firefox.exe -P)"

Did not try this, but not sure what "Windows+R > firefox.exe -P" means. Can you help?

more options

It's the keyboard shortcut for Execute in Windows.

more options

Thanks Oxylatium.

I cannot see Vimeo videos on their website in a *new* Firefox profile.

more options

What's the version number of your Flash plugin?

more options

Oxylatium

Is this the relevant information?

Shockwave Flash

   Version: 11.1.102.55
   Shockwave Flash 11.1 r102

NB - Adobe Shockwave Player 11.6.3.633 is not supported for Win2000

more options

Have you installed Ask.com toolbar on your computer? It's known to be buggy with Flash+Firefox.

more options

Thanks again Oxylatium, but I don't have that toolbar installed.

When I switched on this morning, there was a Shockwave Flash update offered to me, but it has not changed the information given above and it has not changed the situation.

more options

Are you able to right-click on the placeholder for the video and get the Flash player options? Could there be a proxy or other network software that could be blocking vimeo and vimeocdn. Please also check the Flash Player control app in the OS Control Panel: Storage > Local Storage Settings by Site, if either vimeo or vimeocdn is listed it should be Allow or at least Ask me for permission.

more options

Thanks Vivek.Wilfred

Cannot get Flash Player options on the Vimeo video "blank space".

A different machine (running Win XP) can display the video, so no home network or ISP settings blocking Vimeo. [I have also now reluctanty used MS-IE on this machine and that opens the video.]

"Please also check the Flash Player control app in the OS Control Panel" Not sure how to find this, but have now used the "Settings Manager" via:

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager.html

and Vimeo is not listed on any of the pages there.

(NB Win 2000 Control Panel does not have a Storage link.)

Not sure any of this will help, but thanks for the suggestions.

more options

I am not sure about the Flash Player applet in Windows 2000, but I think all recent versions of Flash players use the local Flash Player control panel applet for the global settings instead of the web based settings manager.

Modified by Vivek

more options

Further research warranted for this issue. The videos on the Vimeo site play as intended here but the video on the Wordpress site doesn't. Disabling addons, etc. doesn't work, new profile doesn't work. I noticed that the space on the page where the video is located is blank until clicked on.

more options

Vivek.Wilfred: On pages where I have a viewable video I can get a Settings manager to appear, but it has far less options than the web based one.

dad7732: On the WP site no matter where I click in that space, nothing happens. Interested to hear that you can view on the Vimeo site, but not the embedded one.

more options

Actually there is another local settings manager which supersedes the online manager, that is the default in newer flash players. It would be in the OS Control Panel. Please see this.

You can also try changing the useragent to another Windows version (eg. Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1) with an add-on and see if that makes any difference.

Perhaps, as dad7732 has noted, there could also be another reason.

more options

Vivek.Wilfred: Thank you again for your suggestions.

I agree the flash player should be there as per the info on the above page which states, "Windows: click Start > Settings > Control Panel > Flash Player" However, it is not. See attached screenshot.

Have tried the user agent switcher add-on, but it did not change any thing :{

There seems to be something deeper in my system than the usual fixes. However, it is not worth spending a lot of time on unless others report similar problems.

Modified by Randall

more options

The problem was solved for me by disabling FlashBlock. You can disable/enable FlashBlock on a site by site basis. If you have the addon NoScript, disable it for the Vimeo Site(s).

more options

dad7732: Thanks, but I don't have either add on installed.

more options

Can you open that video directly?

  1. 1
  2. 2