X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox update page keeps opening in a new tab every time I open Firefox. How do I stop this?

Posted

Every time I open up Firefox, the update checking window opens first, then I get 2 tabs that open. One is my home page, the other is the page that opens after a new version of Firefox is installed. How can I get the Firefox update page to stop opening? I had the same thing happen with the "Download Helper" add-on. The only way I could get it to stop was to disable it. I am running windows 7 and Firefox 9.

Chosen solution

Please try creating a new profile and check if the problem persists.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Today

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Version 2.5.8.4958
  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.660
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.2.265
  • NPWLPG
  • npapicomadapter
  • CANON iMAGE GATEWAY Mycamera Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Vivek 310 solutions 2084 answers

Hi,

Please check if there are more than one entry in Tools (Alt + T) > Options > General > Home Page:.

...............................................................................................................................

Useful links:

All about Tools > Options

Going beyond Tools > Options - about:config

about:config Entries

Page Info Tools (Alt + T) > Page Info, Right-click > View Page Info

Keyboard Shortcuts

Viewing Video without Plugins

Firefox Profile Folder & Files

Firefox Commands

Basic Troubleshooting

After Upgrading

Safe Mode

Problematic Extensions

Troubleshooting Extensions and Themes

Troubleshooting Plugins

Testing Plugins

Question owner

There is not. When I open Firefox, the first thing that happens is a window opens up that says it is checking for add-on compatibility, then the 2 tabs open up. One is my home page, the other is the "Hooray! you have the latest version of Firefox" or something like that.

Question owner

"Hooray! Your Firefox is up to date."

Vivek 310 solutions 2084 answers

Please see if there's an updates.xml file in the Firefox installation directory and delete it.

Question owner

These are the only update references I could find: update.locale LOCALE file updater Application updater Configuration settings

Should I do anything with these?

Vivek 310 solutions 2084 answers

Please see this.

Question owner

It's not an issue with Downloadhelper. It's FF.

Vivek 310 solutions 2084 answers

Hi tomburt61,

Please see this

Question owner

Besides the update tab opening up with my homepage tab every time I open FF, I also cannot save any preference changes. So I followed the instructions for "Corrupt preferences file" and that did not work. I don't know what else to do.

Vivek 310 solutions 2084 answers

You can try to delete all files starting with pref. in the profile folder. This would reset all preferences to Firefox defaults and delete those of the add-ons. You would have to exit Firefox before trying to delete.

Question owner

I have already done this. There is only one 'prefs' file.

Vivek 310 solutions 2084 answers

Chosen Solution

Please try creating a new profile and check if the problem persists.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to delete or rename/move the prefs.js file and other possible prefs-##.js with a number and user.js files in the Firefox Profile Folder.

See these articles for some suggestions:

Question owner

I fixed it by creating a new profile. Thanks a bunch!