X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop FF 9.0.1 from checking compatibility of add-0ns every start-up and opening tabs about add-ons along with home page?

Posted

Updated to 9.0.1. Repeatedly set Home Page, but FF starts by checking compatibility of add-0ns--then opens with tabs about the addons along with the Home Page.

Updated to 9.0.1. Repeatedly set Home Page, but FF starts by checking compatibility of add-0ns--then opens with tabs about the addons along with the Home Page.

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.1 r102
  • GEPlugin
  • Coupons, Inc. Coupon Printer Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729) FBSMTWB

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40297 answers

Your UserAgent string in Firefox is messed up by another program that you installed.
http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

Your UserAgent string in Firefox is messed up by another program that you installed. <br /> [http://en.wikipedia.org/wiki/User_Agent] type '''about:config''' in the URL bar and hit Enter <br /> ''If you see the warning, you can confirm that you want to access that page.'' <br /> Filter = '''general.useragent.''' <br /> Right-click the preferences that are '''bold''', one line at a time, and select '''''Reset'''''. <br /> Then restart Firefox

Question owner

It didn't help. Still starts up checking add-on compatibility, then opens tabs for Readabilty and Faster Firefox (both of which I love), along with the desired Home Page.

It didn't help. Still starts up checking add-on compatibility, then opens tabs for Readabilty and Faster Firefox (both of which I love), along with the desired Home Page.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers
See: *http://kb.mozillazine.org/Preferences_not_saved *https://support.mozilla.org/kb/Preferences+are+not+saved *https://support.mozilla.org/kb/Firefox+has+just+updated+tab+shows+each+time+you+start+Firefox ---- *https://support.mozilla.org/kb/Finding+your+Firefox+version *https://support.mozilla.org/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

Modified by cor-el

Question owner

No luck. No matter what I try, FF9.0.1 starts by checking add-on compatibilities and starting with a couple of tab about add-ons and the FF Welcome--you're all up to date screen--along with whatever page I set as Home.

I tried removing the offending add-ons and reinstalling them, but it didn't change anything.

No luck. No matter what I try, FF9.0.1 starts by checking add-on compatibilities and starting with a couple of tab about add-ons and the FF Welcome--you're all up to date screen--along with whatever page I set as Home. I tried removing the offending add-ons and reinstalling them, but it didn't change anything.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Which anti-virus software and which firewall are you running?

Which anti-virus software and which firewall are you running?

Question owner

Running updated McAfee Viruscan Enterprise 8.7.0i behind Windows XP Firewall. I did not have this problem prior to updating to FF 9.0.1

It is not a serious thing, but aggravating and seems like it should not be so difficult to fix.

Running updated McAfee Viruscan Enterprise 8.7.0i behind Windows XP Firewall. I did not have this problem prior to updating to FF 9.0.1 It is not a serious thing, but aggravating and seems like it should not be so difficult to fix.
mrgrabinski 0 solutions 1 answers

Any solution? I have the same problem since updating. Tried stopping it completely using about:config and deleting pref file. All addons upto date Still no luck...annoying.

Ok. I just went through the solutions again and the one provided by the-edmeister seems to have worked. Cheers.

Any solution? I have the same problem since updating. Tried stopping it completely using about:config and deleting pref file. All addons upto date Still no luck...annoying. Ok. I just went through the solutions again and the one provided by the-edmeister seems to have worked. Cheers.

Modified by mrgrabinski

CanadianKat 0 solutions 12 answers

I have this problem too and I find it very annoying. I tried what ed-meister suggested but none of my items in general: useragent were bold. I have also deleted personas and removed them all (50 times at least !!)but the next time I open FF there they all are back again, every single one of them..I want them gone and will start fresh.

I have this problem too and I find it very annoying. I tried what ed-meister suggested but none of my items in general: useragent were bold. I have also deleted personas and removed them all (50 times at least !!)but the next time I open FF there they all are back again, every single one of them..I want them gone and will start fresh.
markbsimon 0 solutions 6 answers

I am having the same problem and have tried all the advice in this forum. I also have firefox loading the mozilla.org each time too. VERY ANOYING!! I suppose time to switch browser!!

I am having the same problem and have tried all the advice in this forum. I also have firefox loading the mozilla.org each time too. '''VERY ANOYING!! ''' '''I suppose time to switch browser!!'''
whoube 0 solutions 2 answers

Addon compatibility check/Mozilla .org EVERY TIME I go online, started after last update. Nothing stops it. Google Chrome is looking better by the minute.

Addon compatibility check/Mozilla .org EVERY TIME I go online, started after last update. Nothing stops it. Google Chrome is looking better by the minute.
whoube 0 solutions 2 answers

32 people????? 32 hundred, thousand maybe. What started as a mild nuisance is becoming a major pain in the butt. Do you think somebody could address this issue? (Seriously !)

32 people????? 32 hundred, thousand maybe. What started as a mild nuisance is becoming a major pain in the butt. Do you think somebody could address this issue? (Seriously !)
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

This is either a problem with the preferences or a problem with the extensions database files. For the first see the post about preferences not saved.
Also make sure that you do not have security software that restores files in the Firefox Profile Folder to previous versions on the next reboot.


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to check if there is a compatibility update available.


You can try to reset Firefox and create a new profile if you run a Firefox 13+ version.

This is either a problem with the preferences or a problem with the extensions database files. For the first see the post about preferences not saved.<br /> Also make sure that you do not have security software that restores files in the Firefox Profile Folder to previous versions on the next reboot. ----- It is possible that there is a problem with the file(s) that store the extensions registry. Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to check if there is a compatibility update available. ---- You can try to reset Firefox and create a new profile if you run a Firefox 13+ version. *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems