Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have Mac running 10.4.11 and Firefox 3.6.25, and FF keeps telling me to upgrade to the latest compatible upgrade, but I can find no evidence on their site that something better exists.

  • 2 replies
  • 13 have this problem
  • 39 views
  • Last reply by 19jamal

more options

Mac OS 10.4 is the limit for my old Mac. I get the message that I should upgrade to a newer version of Firefox than 3.6.25, but the "tell me more" and other links it presents me offer no hint of that newer compatible version.

Chosen solution

Firefox 3.6.x is the last version of Firefox available from Mozilla for PPC Macs and 10.4.
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

Firefox 3.6.x is the last version of Firefox available from Mozilla for PPC Macs and 10.4.
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

more options

Thanks for the good info. I'm using Tenfour to post this reply. Everything looks good!