Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extensions don't work

  • 14 replies
  • 9 have this problem
  • Last reply by KrisRH

more options

Over the last few days a few extension stopped working. I was also having trouble from your servers when updating extensions. There were also lots of problems accessing websites. So I upgraded to 8.0.1 from 8.0. Extension problems continue. I can access websites now.

This is what happens with extensions that don't work. If I reinstall them they start working. But with a new browser session the next day after rebooting my laptop, these same extensions stop working again.

This doesn't seem like an individual extension problem, but a browser problem. I really need it resolved. Please advise. The extensions are listed below. What happens with feedly is a little different. It opens my feedly in a new tab with a new browser session. There's no preference to adjust this in feedly itself, or an option to select it to do that. And my browser option for homepage on browser start up is not feedly.

F.B. Purity, Missing e, Rapportive, feedly

Modified by selftaught

All Replies (14)

more options

Anyone? All problems still continue...

more options

Does it still happen if you update to Firefox 9.0 or 9.0.1?

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is a compatibility update available.

more options

Thanks. 9.0.1 did not make any difference. I know how to update extensions. And there are no problems installing extensions. Even already installed ones install again nicely. That's how I get the ones that don't work to work. It's just that on the next browser sessions these same stop working.

And all my extensions are compatible. I guess it may be a corruption. I don't feel comfortable deleting FF files unless several of you assure me they will be recreated. I still don't understand why only a few extensions are affected and the others work fine.

Feels like a problem with FF at a global level to me.

more options

I think you must re-think cor-el reply to "Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required. See "Corrupt extension files" "

you have already seen :

thank you

more options

The knowledgebase article indicates it's safe to delete these files. Will wait to see if it corrects itself. If not, will try this solution. Thanks!

more options

None of the above worked. I lost ALL my extensions and reinstalling them is creating many new headaches. Only one extension works. The whole Add-ons 'page' in FF is messed up. Extension icons don't appear next to each one; that screen freezes, can't click options, can't close FF... have to go to CTRL-ALT-DELETE. I really, really don't think this is a problem with my profile files or anything local. This is a global FF browser problem and I wonder if anyone who can do something about it is aware, cares or if anything will be done.

My browsing experience is ruined. Merry Christmas!

I have 9.0.1 now...

more options

Did you check on the "Firefox/Tools > Add-ons > Extensions" page to see if there are disabled extensions? If you see disabled extensions then enable them and also do a check for updates via the Tools icon.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

You can do a clean reinstall and delete the Firefox program folder (C:\Program Files\Mozilla Firefox\) to be sure that there isn't a problem with files in that folder.

Download a fresh Firefox copy and save the file to the desktop.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

more options

I know enough to see if any extensions are disabled, or need update, plus auto update is on.

Nothing above has worked. I did the clean reinstall. I did it again to a new directory. I even installed 8.0.1 and updated to latest version from FF. It was version 8 and 8.0.1 I started having these problems so not sure why I though it would work. Going to have Christmas now with a broken browser! Can't give this anymore time. Isn't there a way to report such things to the developers directly. I firmly believe this is a global FF issue, probably related to the update itself and/or their extension servers.

more options

I don't show the default theme under Appearance. I use only the default. Thinking this may be breaking my FF, I installed a couple of themes. The default still doesn't show and I've no way of selecting one of the other two I installed. That's fine, this was a test. Still don't see the default listed there, although FF is open in default theme.

I also installed a Persona and FF did not change a thing on restart. It also doesn't appear in Appearance. Shouldn't the default theme be listed there at least?

more options

Ever since 9.0.1 the FF message to help Mozilla by sending anonymous info also appears with each browser session. No matter is I say Yes or No the message reappears every time. Am I really the only one having this kind of weird behavior? Is there another update planned?

Modified by selftaught

more options

Please also try resetting all preferences including those of the add-ons. Start Firefox in Safe Mode, choose Reset all user preferences to Firefox defaults in the first screen and then Make Changes and Restart.


Useful links:

All about Tools > Options

Going beyond Tools > Options - about:config

about:config Entries

Page Info Tools (Alt + T) > Page Info, Right-click > View Page Info

Keyboard Shortcuts

Viewing Video without Plugins

Firefox Profile Folder & Files

Firefox Commands

Basic Troubleshooting

After Upgrading

Safe Mode

Problematic Extensions

Troubleshooting Extensions and Themes

Troubleshooting Plugins

Testing Plugins

more options

I tired safe mode a bunch of times. This is not an ordinary problem. Hardware acceleration is unchecked... None of the usual recommendations work. I don't think there's anything in any Mozilla documentation for what my FF is doing.

more options

Try to reset all preferences.

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.


more options

Before I updated Firefox on my computer from version 10 to 10.0.1, I installed the extension 'TweakTube - YouTube Enhancer / Video Downloader', and it worked fine with FF 10, but after updating to FF 10.0.1, the mentioned extension prevented video's from playing on YouTube, that is until I used the described solution in this support forum. Thank you so much for making such a superb web browser.

- KrisRH