Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The automatic updating is far behind.

  • 4 replies
  • 2 have this problem
  • 1 view
  • Last reply by hares

more options

Why doesn't firefox automaticly update to the latest ?It is now only updated to 3.6.24.

Chosen solution

Since you have both the old OSX 10.4 and PPC hardware be glad you did not get a updates to Firefox 8.0.1

As of Firefox 4.0 and newer one needs both OSX 10.5+ and Intel hardware. http://www.mozilla.org/en-US/firefox/8.0/system-requirements/

Two options since you have PPC: either continue to use Firefox 3.6 (3.6.24 is current)

Or you can use a third-party build from http://www.floodgap.com/software/tenfourfox/ in order to have Firefox 8.0 though do note http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Since you have both the old OSX 10.4 and PPC hardware be glad you did not get a updates to Firefox 8.0.1

As of Firefox 4.0 and newer one needs both OSX 10.5+ and Intel hardware. http://www.mozilla.org/en-US/firefox/8.0/system-requirements/

Two options since you have PPC: either continue to use Firefox 3.6 (3.6.24 is current)

Or you can use a third-party build from http://www.floodgap.com/software/tenfourfox/ in order to have Firefox 8.0 though do note http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

more options

Sorry, the Mac that you posted here with can't run any Firefox 4+ versions, which need an Intel processor and 10.5 or later.
http://www.mozilla.org/en-US/firefox/8.0/system-requirements/

Firefox 3.6.24 is the latest version that is compatible with what you have. Firefox 3.6.25 will probably be released next week. Support for the 3.6 version is slated to continue until at least Apr 24, 2012.

more options

Thanks very much edmeister, I had an inkling that might be the problem.

more options

Thanks a lot. I do have a very old mac .