X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

after downloading new version I still get message I am not protected

Posted

I follow all your instructions, download new version and still get same warning I am no longer protected

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 GTB7.1

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

You download it but do you install it ?

see here for more information:

Installing Firefox on Mac


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.