Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i don't use facebook firefox and am suddenly been bombarded with Firefox boxes asking me what to do with downloads all concerning facebook


Hi there Since switching my computer on a short time ago, I have repeatedly been receiving those boxes where Firefox asks me what I wish to do with this download as in what I wish to open it with? They are all to do with Facebook, and I don't use Facebook,don't have or want a Facebook account. The box says: Opening Like.php You have chosen to open like.php which is a Plain Text (-1bytes) from:http://www.facebook.com what should Firefox do with this file?. Open with TextEdit(default) Save with Do this automatically Cancel OK

Also when cancelling the box another one or two of the same boxes appear. It's extremely concerning and I'm currently running MacScan and iAntivirus to see if I have a problem on my Mac. I'm using Firefox 8.0.1 and Mac Snow leopard.

To answer the first question below, "this Happened" it's just started to happen today and has been about 7/8 times so far, but the menu doesn't allow for that answer.

Thanks Tweed

Modified by Tweed

Additional System Details

This started when...


Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • BlackBerry AppWorld plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 4.0.51204.0
  • iPhoto6


  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Helpful Reply

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

See also:

Question owner

Thanks, I'll give it a try.