Question

Firefox about says I have version 8.0.1 then ATT website says supports versions 4 and higher and google 4 and higher and bother say upload latest brower; firesfox tax beta says I already have.

I have firefox 8.0.1 "says" beta version on the tab but supposedly latest browser version. When trying to use gmail, or ATT websites for account purposes and several other sites and also occasionally I get dialog boxes that I need to get more modern browser., e.g. ATT supports firefox 4.0 and higher. Well!!! I have supposedly 8.01??? Whats going on with 8.01 and inability with used sites I have uninstalled all other versions. Answers suggestions?

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • post