X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

unable to install adobe flash player/firefox/

Posted

hours of work alone and with amazon support and still unsucessful at installing adobe flash player. Message says it has been successfully installed, but every t ry at using amazon prime's streaming video gets message it is not installed.

Read that it cannot be straightforwardly installed on Windows 7 operating system when firefox is the browser.

I hope someone can provide me with clear, straightford ward directions about how to do this. Think of telling your grandmother how: mini steps, where to look for the icons or directions you are talking about. single click or double....

Trust me, I worked with an Amazonll technician for over one hour, tried to install aat least 20 times and failed (remember it "tells me" it has been installed, but it ain't working)

So, what are the secrets? More thanks than you can possibly imagine from one frustrated firefox user.

Marie

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-In 3.0.1.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24403 answers

There are two different versions of Flash, the ActiveX version for IE and the Plugin version used by most other browsers.

1.Download the Flash Plugin version setup file from here:
Adobe Flash - Plugin version.
Save it to your Desktop.

2. Close Firefox using File > Exit
then check the Task Manager > Processes tab to make sure firefox.exe is closed,
{XP: Ctrl+Alt+Del, Vista: Shift+Ctrl+ESC = Processes tab}

3. Then run the Flash setup file from your Desktop.

4. Start Firefox and test your installation here: https://www.adobe.com/software/flash/about/

  • On Vista and Windows 7 you may need to run the plugin installer as Administrator by starting the installer via the right-click context menu if you do not get an UAC prompt to ask for permission to continue (i.e nothing seems to happen).

See this:
http://vistasupport.mvps.org/run_as_administrator.htm