X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My browser window and secure sites state I have an outdated version of Firefox though the 'about firefox' states its version 8....whats going on and how do I fix?

Posted

When I open the browser window (with Google as the homepage) this message is there..."URGENT! Your version of Firefox is no longer protected against online attacks. Get the upgrade - it’s fast and free! "...I have upgraded several times using the link but the warning continues. When I am in sites like Paypal this warning is stated "Update your browser: It looks like you're using an older browser that may have security issues. Help protect your account. " When I follow the HELP prompts to assess my current version in 'About Firefox' in the help menu it states that Firefox is up to date and 8.

Chosen solution

Additional System Details

This happened

Every time Firefox opened

This started when...

for months now...

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • 4.0.60831.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • NPWLPG
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Office Live Update v1.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 10.2
  • npvideoegg-loader
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)

More Information

No HELP has been offered in troubleshooting....

Swarnava Sengupta 483 solutions 3135 answers

Chosen Solution

Try what edmeister suggested here

let me know

Question owner

Thank you to Swarnava and Edmeister...Problem solved!