X
Tap here to go to the mobile version of the site.

Support Forum

Address bar does not display current tab FULL URL

Posted

The address bar does not show the current tabs FULL URL. I have tried the Trim URL trick to no avail. It is also disheartening that there is no COPY LINK option in the file menu. I need to be able to see the full URL and be able to copy it for a host of reasons. Would also be nice to make sure that I am on an HTTPS page and not have to guess. Take a look at this website and see that no matter what page you go to, the URL stays the same.

Really would like to know the reason that FF took it out of the mix, what is the problem or issue or was it just someone's idea of a cute piece of code?

The address bar does not show the current tabs FULL URL. I have tried the Trim URL trick to no avail. It is also disheartening that there is no COPY LINK option in the file menu. I need to be able to see the full URL and be able to copy it for a host of reasons. Would also be nice to make sure that I am on an HTTPS page and not have to guess. Take a look at [http://friendsofprovisoeasths.ning.com/ this website] and see that no matter what page you go to, the URL stays the same. Really would like to know the reason that FF took it out of the mix, what is the problem or issue or was it just someone's idea of a cute piece of code?

Modified by mikeeusa714

Chosen solution

If you are on a secure HTTPS connection then you will always see the https: protocol. Only the http: protocol is hidden.

If a page uses frames and other pages are opened in a frame then you will not see the link of that frame in the location bar.
You can right click on a web page to see if frames are used (This Frame > View Frame Info)


If your brightness and contrast settings are wrong then you may only see the domain highlighted.

You can set the pref browser.urlbar.formatting.enabled to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly.

Read this answer in context 5

Additional System Details

This happened

Every time Firefox opened

This started when...

with 7.0

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.0 r1
  • 4.0.60831.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • GEPlugin
  • getplusplusadobe16263
  • 2.23.1.0 - The WorldWinner plug-in allows you to enjoy online casual games with the thrill of playing for cash and prizes
  • Garmin Communicator Plug-In 2.8.3.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • npmnqmp 989898989877
  • DeLorme Send To GPS
  • Java(TM) Platform SE binary
  • Java Plug-in 1.6.0_13 for Netscape Navigator (DLL Helper)
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Coupons, Inc. Coupon Printer DLL
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • 1.7.0036.0
  • Photosynth 1.1.0.602
  • Adobe Shockwave for Director Netscape plug-in, version 10.1
  • IE Tab Plug-in developed by Hong Jen Yee
  • npsnapfish

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

http://friendsofprovisoeasths.ning.com/

cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

Chosen Solution

If you are on a secure HTTPS connection then you will always see the https: protocol. Only the http: protocol is hidden.

If a page uses frames and other pages are opened in a frame then you will not see the link of that frame in the location bar.
You can right click on a web page to see if frames are used (This Frame > View Frame Info)


If your brightness and contrast settings are wrong then you may only see the domain highlighted.

You can set the pref browser.urlbar.formatting.enabled to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly.

If you are on a secure HTTPS connection then you will always see the https: protocol. Only the http: protocol is hidden. If a page uses frames and other pages are opened in a frame then you will not see the link of that frame in the location bar.<br /> You can right click on a web page to see if frames are used (This Frame > View Frame Info) ---- If your brightness and contrast settings are wrong then you may only see the domain highlighted. You can set the pref <b>browser.urlbar.formatting.enabled</b> to <i>false</i> on the <b>about:config</b> page to disable the highlighting of the domain and see the full URL more clearly.
gremlinone 0 solutions 1 answers

I noted the same problem, "http://" is now being filtered from the link line. I used to be able to copy and paste the address bar text into an email, hit enter and it becomes a clickable link. NOW I have to manually add "http://" to the beginning every time I paste.

I noted the same problem, "http://" is now being filtered from the link line. I used to be able to copy and paste the address bar text into an email, hit enter and it becomes a clickable link. NOW I have to manually add "http://" to the beginning every time I paste.

Question owner

YUP, very aggravating and the fact that there is no Copy Link in the menu bar means that you have to become very creative to copy the URL. I wonder sometimes why some folks feel the need to change the way something works just so that they can justify their existence. Microsoft is famous for this type of job protection, guess Mozilla is heading that way also.

YUP, very aggravating and the fact that there is no Copy Link in the menu bar means that you have to become very creative to copy the URL. I wonder sometimes why some folks feel the need to change the way something works just so that they can justify their existence. Microsoft is famous for this type of job protection, guess Mozilla is heading that way also.
AlanWW 0 solutions 1 answers

Helpful Reply

You can show the full URL by going into about:config and browse to browser.urlbar.trimURLs click on the value and it will change from True to False. You will now see the full address.

You can show the full URL by going into about:config and browse to '''browser.urlbar.trimURLs''' click on the value and it will change from True to False. You will now see the full address.

Question owner

sorry alanww and any others who suggest the trim function. it kinda works but doesn't. if you have 2 or more tabs open and switch them back and forth "sometimes" the full path will show but for the most part it will not.

sorry alanww and any others who suggest the trim function. it kinda works but doesn't. if you have 2 or more tabs open and switch them back and forth "sometimes" the full path will show but for the most part it will not.
nerdgrim 8 solutions 24 answers

For what it's worth, in Firefox 9 "https" IS displayed but "http" is NOT displayed.

For both, however, if you click inside the nav bar, the full URL is automatically selected. Then right click and select "Copy" (or CTRL + C) and the FULL url is copied to the clipboard (works for HTTP and HTTPS).

Hope this helps.

For what it's worth, in Firefox 9 "https" IS displayed but "http" is NOT displayed. For both, however, if you click inside the nav bar, the full URL is automatically selected. Then right click and select "Copy" (or CTRL + C) and the FULL url is copied to the clipboard (works for HTTP and HTTPS). Hope this helps.

Helpful Reply

OK, take a look at the screenshot that I just took. I had started off on Facebook which is still in the Nav Bar as www.facebook.com. I then went to the FF Add-on's Manager and the Nav Bar stilled showed the FB url but FB was nowhere to be found as it had been replaced in the active tab by Add-on's Manager. I then used my Yahoo! toolbar and went to Yahoo Groups in a new tab. As you can see the nav bar continues to show FB. I tried your copy/paste idea and it only copied the FB url and not the entire FB url. THIS is what I am talking about. The only way I can consistently do a copy/paste of the full url is go to Tools and then Page Info and copy the url from there. I have given up on finding a fix as I don't think there is one that will work for everyone, and now have turned my attention to asking the folks at Mozilla WHY ARE ADDING CUTE LITTLE TWEEKS TO THE BROWSER THAT ARE JUST FLUFF??? Why have they not stepped in on this issue and given a reason or a fix?? Just like when they moved the tab placement, who asked them to and why didn't they make it an option and not make me have to jump through hoops to get it back to where it made sense to have the tabs?? Am I ticked off,,,you bet. Always someone needing some job security and fixing something that ain't broke. Probably some Occupy sympathizers, same mentality!!

OK, take a look at the screenshot that I just took. I had started off on Facebook which is still in the Nav Bar as www.facebook.com. I then went to the FF Add-on's Manager and the Nav Bar stilled showed the FB url but FB was nowhere to be found as it had been replaced in the active tab by Add-on's Manager. I then used my Yahoo! toolbar and went to Yahoo Groups in a new tab. As you can see the nav bar continues to show FB. I tried your copy/paste idea and it only copied the FB url and not the entire FB url. THIS is what I am talking about. The only way I can consistently do a copy/paste of the full url is go to Tools and then Page Info and copy the url from there. I have given up on finding a fix as I don't think there is one that will work for everyone, and now have turned my attention to asking the folks at Mozilla WHY ARE ADDING CUTE LITTLE TWEEKS TO THE BROWSER THAT ARE JUST FLUFF??? Why have they not stepped in on this issue and given a reason or a fix?? Just like when they moved the tab placement, who asked them to and why didn't they make it an option and not make me have to jump through hoops to get it back to where it made sense to have the tabs?? Am I ticked off,,,you bet. Always someone needing some job security and fixing something that ain't broke. Probably some Occupy sympathizers, same mentality!!
JohnandVal 1 solutions 3 answers

Allan. I must be thick! Where is the "about:config" that you refer to?? Cheers

John

Allan. I must be thick! Where is the "about:config" that you refer to?? Cheers John

Question owner

type it into your address bar

type it into your address bar
justaguy11 0 solutions 2 answers

The people responding do not understand the problem, and are not providing a fix for it. I'll try to restate the problem again:

1. The URL displayed on the address bar is not changing when different tabs are clicked. For example, if I have one tab open on CNN, and then I open a tab on MSNBC.....and then I click on the tab for CNN, the address bar still shows the URL for MSNBC. This is not a matter of a truncated URL. The address bar doesn't change when we click among different already-open tabs. 2. Also, the "Back" arrow is disabled. It does nothing. THe only way to go back is to open up the entire history for that tab and pick the previous location from the list. 3. Okay, having said that, I simply want to back out this 10.0 release. It is complete crap. Where can I get the last 9.x release?

The people responding do not understand the problem, and are not providing a fix for it. I'll try to restate the problem again: 1. The URL displayed on the address bar is not changing when different tabs are clicked. For example, if I have one tab open on CNN, and then I open a tab on MSNBC.....and then I click on the tab for CNN, the address bar still shows the URL for MSNBC. This is not a matter of a truncated URL. The address bar doesn't change when we click among different already-open tabs. 2. Also, the "Back" arrow is disabled. It does nothing. THe only way to go back is to open up the entire history for that tab and pick the previous location from the list. 3. Okay, having said that, I simply want to back out this 10.0 release. It is complete crap. Where can I get the last 9.x release?
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40138 answers

@justaguy11

You have something wrong with your Firefox installation, the wrong url is showing for that Fox News tab. More than likely caused by a slightly incompatible add-on.

See this:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

@justaguy11 You have something wrong with your Firefox installation, the wrong url is showing for that Fox News tab. More than likely caused by a slightly incompatible add-on. See this: <br /> http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

Question owner

NOPE, sorry no cigar. I tried it in safe mode, I moved the tabs position up, down and sideways also. But the biggest thing was that even in safe mode the problem was still there.

NOPE, sorry no cigar. I tried it in safe mode, I moved the tabs position up, down and sideways also. But the biggest thing was that even in safe mode the problem was still there.

Question owner

You're right, the pevious folks do not understand the issue and may not have even noticed it before. Glad to hear what you said anout version 10, I was just getting ready to update, think I'll wait a week or so.

You're right, the pevious folks do not understand the issue and may not have even noticed it before. Glad to hear what you said anout version 10, I was just getting ready to update, think I'll wait a week or so.
justaguy11 0 solutions 2 answers

Hey Mike, I managed to fix mine. Here's what I did: 1. I completely uninstalled Firefox 10.0 using the Windows Control Panel->Add or Remove Programs 2. I downloaded version 9.0 from http://www.top10download.com/firefox-9-0 and saved the installation file to my PC. 3. Ran the installation file for 9.01, and disabled all add-ons and extensions. Essentially, an installation from scratch. 4. Behaviour of 9.01 was then fine. Installed the add-ons I normally use. Still fine. 5. Downloaded version 10.0 from http://www.mozilla.org/products/download.html?product=firefox-10.0&os=win&lang=en-US and saved to my PC. 6. Ran the install of 10.0 to a different directory than the 9.0 install using the "custom install" options. (So I'd still have a working copy of 9.0 if the 10.0 failed). 7. Installed all my normal add-ons. 8. Voila! 10.0 now working fine, with tabs working correctly, and with URLs appearing appropriately for each tab.

 My guess is that 10.0 is not compatible with one (or more) of the add-ons that it says will work, and which I had previously working under 9.0. I deleted about 10 add-ons during this "start from scratch" process I described above. 
 Please note that I kept a copy of Version 4.0 Beta installed the entire time, under a separate directory...and it continued to work fine the entire time. 
Cheers!
Hey Mike, I managed to fix mine. Here's what I did: 1. I completely uninstalled Firefox 10.0 using the Windows Control Panel->Add or Remove Programs 2. I downloaded version 9.0 from http://www.top10download.com/firefox-9-0 and saved the installation file to my PC. 3. Ran the installation file for 9.01, and disabled all add-ons and extensions. Essentially, an installation from scratch. 4. Behaviour of 9.01 was then fine. Installed the add-ons I normally use. Still fine. 5. Downloaded version 10.0 from http://www.mozilla.org/products/download.html?product=firefox-10.0&os=win&lang=en-US and saved to my PC. 6. Ran the install of 10.0 to a different directory than the 9.0 install using the "custom install" options. (So I'd still have a working copy of 9.0 if the 10.0 failed). 7. Installed all my normal add-ons. 8. Voila! 10.0 now working fine, with tabs working correctly, and with URLs appearing appropriately for each tab. My guess is that 10.0 is not compatible with one (or more) of the add-ons that it says will work, and which I had previously working under 9.0. I deleted about 10 add-ons during this "start from scratch" process I described above. Please note that I kept a copy of Version 4.0 Beta installed the entire time, under a separate directory...and it continued to work fine the entire time. Cheers!
musr 2 solutions 14 answers

"If you are on a secure HTTPS connection then you will always see the https: protocol. Only the http: protocol is hidden. "

that is not the case. "will" --> "should"

"If you are on a secure HTTPS connection then you will always see the https: protocol. Only the http: protocol is hidden. " that is not the case. "will" --> "should"
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

The HTTPS protocol should never be hidden.

Are you using the default theme?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

The HTTPS protocol should never be hidden. * https://support.mozilla.org/kb/Site+Identity+Button Are you using the default theme? Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode
musr 2 solutions 14 answers

Thankyou cor-el for your suggestion. I will try that

Thankyou cor-el for your suggestion. I will try that