Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 8 always asks to enable add-on whenever restarting PC

more options

Although I set all the installed addons "enable", whenever I start-up the PC, Firefox disables all the things, ask again and force me to manually enable them one by one! Actually it doesn't remember my setting for addon!

Chosen solution

I have the same issue and none of the suggested solutions here worked to resolve the issue. I have 3 add-ons and the issue occurs on all of them. Also as with others it only started with Firefox 8.

Also use BitDefender v10, and have tried uninstalling / re-installing both BitDefender and Firefox with no luck.

UPDATE: Upgraded to BitDefender v12 (you can do this for free if you have a valid license for v10) and it resolved the issue.

Read this answer in context 👍 4

All Replies (16)

more options

umm anyone helps?

more options

Which security software (firewall, anti-virus) do you have?

It is possible that security software restores files in the Firefox Profile Folder on a reboot.


See also:

more options

umm i don't know but why firefox 7 was ok when firefox 8 has this problem?

more options

also I'm using BitDefender 2010

more options

still have the problem

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

I have tried creating a new profile but not work.

more options

me too,I have tried this,but the new profile has same problem with the old one :( I'm using BitDefender 2010

more options

still can not solve it. I am waiting for any fix from FF

more options

Chosen Solution

I have the same issue and none of the suggested solutions here worked to resolve the issue. I have 3 add-ons and the issue occurs on all of them. Also as with others it only started with Firefox 8.

Also use BitDefender v10, and have tried uninstalling / re-installing both BitDefender and Firefox with no luck.

UPDATE: Upgraded to BitDefender v12 (you can do this for free if you have a valid license for v10) and it resolved the issue.

Modified by denikar

more options

Same issue here. Also using BitDefender 2010. Nothing is working.

Modified by nyjfootball

more options

Umm, thank you. But I may need a stable fully fixed Firefox 9 for this problem. Or is there any hotfix from Mozilla?

more options

Mozilla isn't going to "fix" something that is caused by an external application, whether it a security application or not. denikar said that his problem was fixed by upgrading to BitDefender v12, so the problem is probably with BitDefender v10.

more options

no, there should be some problem with the Enable - Add - On when open Firefox. This new feature has just come out since Firefox 8. Firefox 7 did not have this and everything used to be OK.

more options

I updated to Bitdefender 2012 and the problem is solved. Cost me though. Had to purchase a new license. Could not transfer my license from version 2010. That's not right Mozilla! Create a fix!

more options

Quite many has this issue