Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to run Java applet in Firefox with next generation plugin disabled.

  • 3 replies
  • 13 have this problem
  • 6 views
  • Last reply by Schaefro

more options

We use an applet that is not "Next Generation Plugin" compliant. In order to run our applet in Internet Explorer we have to disable the "Next Generation Plugin" in the Java plugin control panel. This seems to work with Internet explorer as our applet runs as it always has. The same does not hold true for Firefox from V3.6 up to current v 8.0.

My question is: Does firefox or is Firefox supposed to honor the disabling of the next generation plugin in via the java plugin control panel or is it implicit that any applet that you intend to run in firefox should be of the "next generation plugin" architecture. I have tried to find this question in blogs and discussions but have come up empty. From my research so far it seems that if you want to run an applet in Firefox v3.6 or higher you must use Java 1.6.0_10 or higher and your applet must conform to the "Next Generation Plugin" architecture.

All Replies (3)

more options

See --> https://www.java.com/en/download/faq/firefox_newplugin.xml (be sure to read the "More Technical Information" section).


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Thanks,

 I found the link above earlier this week. It's clear that if you run Java applet's in Firfox that Java 1.6.0_10+ must be used, this is not the issue. We are using Java 1.6.0_10+. 

My question is will Firefox 3.6 and above support running an applet in Java 1.6.0_10+ that is not "Next Generation Compliant". As I mentioned in the original post we are able to disable the "Next Generation Plugin" via the java plugin control panel. In this mode we are able to run our applet in Internet Explorer with no problems. We are not able to run the same applet in Firefox with this option disabled in the Java plugin.

Is it a requirement that if you run an applet in Firefox V3.6 0 or above that the applet be "Next generation Plugin" compliant?

more options

If the requirement is to enable the "Next generation Plugin" via the Java Plugin control panel will Firefox support running a an applet that is not "next generation" compliant?