Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Mac cannot be upgraded beyond its current 10.4.11, does this mean I will no longer be able to use firefox?

  • 2 replies
  • 19 have this problem
  • 2 views
  • Last reply by Zanswerman

more options

Should I simply start using Safari exclusively? If so when?

Chosen solution

Firefox 4 versions and later do not run on a PowerPC Mac.
Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 8 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Firefox 4 versions and later do not run on a PowerPC Mac.
Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 8 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:

more options

Thank you. I worry about the unofficial version, viruses? failures, freezes, etc.

Do I install over the existing version?
Am I better off simply using Safari?

Modified by Zanswerman