X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Even tho I've downloaded FF7.0.1, both FF and Google tell me I have an old version of FF and I should upgrade!

Posted

Google won't let me on Google+ until I upgrade (which I have, twice), but more astonishing, FF insists I need to upgrade (claims I'm running 3.5.1!

Chosen solution

That worked! Thanks for your help.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.0 r1
  • Coupons Inc., Coupon Printing FireFox Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 4.0.60531.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Plug-in for Starfield utilities
  • Office Live Update v1.0
  • npmnqmp 071101000050
  • iPhoto6
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

More Information

Check your guess as to which FF version Im using---3.5.1
FF thinks I'm using Mac OS 10.5. I'm actually using Mac OS 10.7.2

Question owner

I inactivated all my add-ons. They are not the problem. But I don't want to mess with the user-agent. Any other ideas?

I can't believe Mozilla can't recognize it's own version of FF!!

knorretje 161 solutions 582 answers

You can find the real Firefox version in the Help>About Firefox screen.
https://support.mozilla.com/en-US/kb/Finding%20your%20Firefox%20version
At this moment you are telling everyone that you have version 3.5.1, and that is what we recognize on this forum. We have no reason to assume that this is wrong.
Like the-edmeister said, it is possible that you useragent information is wrong and needs to be corrected.

Question owner

"About Firefox" on my computer verifies that I am using 7.0.1.

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Your Firefox UserAgent is messed up and is telling websites you visit that you are using Firefox 3.5.1.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Reset the prefs related to the UserAgent as described in the article that I hyperlinked in my first answer.

Question owner

I tried to make the mods, but Reset for general.useragent.locale is greyed out. The other options for useragent, don't appear.

Modified by sonster

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Helpful Reply

Put this string - general.useragent. - in the Filter line at the top so you can see all the prefs related to the UA setting all at once. Reset any that are bold. Prefs that aren't displayed in a bold type are already at their default setting and don't need to be reset.

Chosen Solution

That worked! Thanks for your help.