X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 7 won't play YouTube videos

Posted

Running Win7 x64. Upgraded to Firefox 7, then YouTube videos stopped playing. YouTube keeps insisting I need to install the latest flash player, which I have done several times (both "install_flashplayer10_mssa_aih.exe" and "install_flashplayer11x64_mssa_aih" versions), clear cookies, reboot and all that crap. Firefox refuses to play YouTube videos. Internet Explorer 9 (x64) plays YouTube videos fine. Am not using Firefox anymore. You have got to SUPPORT your app instead of leaving users floundering. This is also why I HATE upgrading. It too often causes new incompatibilities when I just want to leave what is working, the hell alone.

Chosen solution

On Adobe forum, someone suggested

   * go to http://forums.adobe.com/thread/909550 and
         o download the 64-bit uninstaller
         o download the 64-bit installer
   * close all browser windows, then run the downloaded uninstaller
   * restart Windows
   * delete any remaining files in
         o C:\Windows\system32\Macromed\Flash
         o C:\Windows\syswow64\Macromed\Flash
   * now run the downloaded installer

This still did not work. Then someone else said to install the ActiveX installer, which I found somewhere online.

THEN it finally worked. But I still dont get why I have to jump thru extra hoops, that are not explained in the first place- YT says I need to upgrade (even though my old W2k machine with FF 3 and Flash 10 is working fine), I click on the link on YT that takes me to Adobe, I download and install as the instructions lead, but that doesnt work. Why doesnt ActiveX install along with the Flash installer if it is necessary?

Read this answer in context 0

Additional System Details

Sites Affected

http://www.youtube.com/

Installed Plug-ins

  • Google Update
  • 4.0.60831.0
  • DivX Web Player version 2.1.2.265

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0

More Information

Tim 150 solutions 1005 answers

You need the 32 bit version of Flash Player 10 (install_flash_player_11_plugin_32bit.exe). Firefox is a 32bit browser so you need the 32bit Flash player

Helpful Reply

Thanks for reply, but it does not fix.

When I click on a YT video, the message reads "You need to upgrade your Adobe Flash Player to watch this video." and " Download it from Adobe" is a link to "Adobe Flash Player 11.0.1.152" which says it includes the 64-bit and 32-bit versions of Flash.

I click "Download Now", download & install "install_flashplayer11x64_mssd_aih.exe" (this updated in the last few hours), that supposedly covers x32. But it still does not work. So where is the mistake? Firefox, YouTube, or Flash? The info necessary to make this work is not adequately explained.

Back on Adobe, I select "Win7 32-bit" and "Flash Player 11 for Other Browsers (32 bit)", and 'Download Now', install "install_flashplayer11x32_mssd_aih.exe". But I still cant play YouTube videos.

What really does not make sense is that I can play YT videos fine in Firefox 3.0.19 on an old Win 2000 machine and some old version of Flash (I cant locate the version #). Again, this is why I hate upgrades. They just create as many new problems as they solve, when the version that worked years ago was just fine.

Modified by Exergone

Tim 150 solutions 1005 answers

What version of flash player does it report you have installed if you open Firefox and go to this url? http://www.adobe.com/software/flash/about/

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Question owner

Am up to Flash v11,0,1,152. Is anyone getting Firefox 7 to play YT videos in Win7 x64? If so, which Flash version are you using?

Please point me at the exact version of Flash (name the version number) you think I should install to get Firefox 7 to play YT videos. But Flash does not seem to be the problem.

No recent Flash versions of 10 and 11 (x32 or x64) work for me in Firefox 7. The Flash installer covers both x32 and x64, so which browser I use shouldnt matter. All Flash versions DO work with IE x64. And Firefox 3 is playing YT vids fine with Flash v10,0,45,2 on Win2K(x32). So the problem seems to be in Firefox 7 in Win7 x64. Maybe Firefox needs to catch up with the rest of the x64 world.

Modified by Exergone

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Can you find the Flash plugin file NPSWF32.DLL for Firefox?

You can find the Flash plugin file NPSWF32.DLL here after you have run the Flash installer:

C:\Windows\SysWOW64\Macromed\Flash\
C:\Windows\System32\Macromed\Flash\

If it is there then create a plugins folder in the Firefox Profile Folder and copy the file to that folder to see if that makes the Flash plugin work.

Question owner

The mozillazine.org site are not accessible for some reason.

But in Firefox, I follow "Help > Troubleshooting Information > Profile Directory: Open Containing Folder" and it leads to "...\AppData\Roaming\Mozilla\Firefox\Profiles\vw1j8del.default".

I made a "plugins" folder inside the "vw1j8del.default" folder.

I copy the "NPSWF32.dll" file from "C:\Windows\SysWOW64\Macromed\Flash" and now I can finally play YT vids in Firefox.

But the question is, why do I have to jump thru all these hoops? Which component isnt working right?

Its very annoying when Firefox keeps nagging to upgrade every other day, then when I do, it screws things up, and I have to waste all this time on forums. Meanwhile, I keep an old W2K machine for email, I avoid upgrading anything on it, and it works just fine. Theres no appreciable difference between Firefox 3 and 7, except 7 is wasting my time.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

The Flash installer should have added a registry key on where to find the Flash plugin.

HKEY_LOCAL_MACHINE\Software\MozillaPlugins

Apparently that hasn't happen in your case.

You can try to run the Flash installer as Administrator in such cases to see if that helps.

Modified by cor-el

young707 0 solutions 4 answers

The latest version of Firefox can be patched to work on flash players

According to instructions above, I copy file NPSWF32.dll

from: C:\Windows\SysWOW64\Macromed\Flash

to: C:\Users\usernamexxx\AppData\Roaming\Mozilla\Firefox\Profiles\ap8ypmhk.default\Plugins

Create this new "Plugins" folder

My system: Windows 7 Ultimate, 64 bits system

Firefox 7.0.1 (installed 10/21/2011)

Adobe Flash Player 11 Active X version 11.0.1.152 installed 10/21/2011

Adobe Flash Player 11 Plugin 64 bit version 11.01.1.152 installed 10/21/2011

Adobe Flash Player 10 Active X 64 bit version 10.3.162.28 installed 4/20/2011

In the FireFox Add-on Shockwave Flash 11.01.152 is now enabled. The version shown is 11.0 r1 last updated 10/21/2011

Modified by young707

Question owner

Registries are beyond me, but I dont know how a registry key can point to a file within a "plugins" folder that does not exist(?). It seems that something is failing to create the necessary plugins folder, or to put the "NPSWF32.dll" file inside it. Is this Flash's or Firefox's responsibility?

I tried uninstalling Flash and removing the manually created plugins folder. Then installing Flash 'Run as administrator' as suggested, but it still does not work as the "plugins" folder and theNPSWF32.dll file are still not created.

I manually placed the plugins folder with the dll back where it was, and YT videos play again.

So we have an obscure workaround, but Flash is still not installing correctly, even as administrator.

Modified by Exergone

timonline 0 solutions 1 answers

Thanks all the help. I got flash 11.x working with firefox 7.0.1 on windows x64

Chosen Solution

On Adobe forum, someone suggested

   * go to http://forums.adobe.com/thread/909550 and
         o download the 64-bit uninstaller
         o download the 64-bit installer
   * close all browser windows, then run the downloaded uninstaller
   * restart Windows
   * delete any remaining files in
         o C:\Windows\system32\Macromed\Flash
         o C:\Windows\syswow64\Macromed\Flash
   * now run the downloaded installer

This still did not work. Then someone else said to install the ActiveX installer, which I found somewhere online.

THEN it finally worked. But I still dont get why I have to jump thru extra hoops, that are not explained in the first place- YT says I need to upgrade (even though my old W2k machine with FF 3 and Flash 10 is working fine), I click on the link on YT that takes me to Adobe, I download and install as the instructions lead, but that doesnt work. Why doesnt ActiveX install along with the Flash installer if it is necessary?

brecky3 0 solutions 1 answers

Helpful Reply

I discovered that the Ad Block Plus addon was the problem. I went into the options for that addon & permanently disabled the plugin for youtube. That was a simple solution. Why didn't FF come up with that?

Question owner

In my case, I dont have Ad Block. I had also disabled all unnecessary plugins beforehand.

sdrees 1 solutions 5 answers

I don't have Ad Block either. What I have been doing is checking back at FF and Adobe for updates and, surprise, both places have unannounced updates that I've tried in the past few days. After a lot of trial and error, most of my problems are gone. I'm now only having problems with some graphics on a few sites. Much better than it was before. I have no problem with email links, etc. I actually have Adobe flash player and plug in installed with FireFox 8 and (knock on wood) most everything is playing).

I wish there had been some acknowledgment from FF that there were/are problems.