Question

I've tried updating my Firefox browser several times, but none of the updates for the newer versions work. I'm running Windows XP and Firefox 3.5. I've tried v.6 & v.7 but they don't open/run. Help please?

As the question says, I can't seem to install v.7 correctly. I can download it. Open the file. Start to install it... but then nothing happens. When I open Firefox again (after rebooting sometimes) I still get version 3.5. Is there something I'm not doing?

Now that I look at the trouble shooting info I'm not sure. Every website I go to that requires a recent version of Firefox says I need to update my browser because it's old. I can't even access Google+ which I would like to use because it thinks my version of Firefox is 3.5. Suggestions?

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • post
  • owner
  • post