Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Does anybody know why Firwfox runs SO slowly on Vista?

  • 10 replies
  • 25 have this problem
  • 29 views
  • Last reply by cfcentaurea

more options

I have a Vista machine. I am running Firefox 7.0.1. Response times have started slowing down. the type rate of characters is jerky and very slow. And the scrolling down screen rate abysmal. Any suggestions what is causing this and how to fix?

All Replies (10)

more options
more options

The default of the pref network.http.max-connections has been increased from 30 to 256 in Firefox 6+ versions.

Try to decrease the value of the pref network.http.max-connections from 255 to a setting like 30 as used in Firefox 3 versions.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Although I also get screen hanging AND high CPU usage, this was not the thrust of the original problem I flagged.

To recap - scrolling down a screen - say in FaceBook or on my email - the scrolling rate is very slow, and choppy in delivery. It's as though FF is delivering packets of characters but very slowly.

And when I first fire up FF I have to go into Tools, into Options, uncheck the 'open a new window in a new tab option' recheck it and save. This then allows FF to open a new window in a new tab. It doesn't take the already checked box as an initial instruction, Once I've done this it stays current until I close FF down, so when I fire it up again, I have to do the same.

more options

In reply to cor-el I don't understand your fix instructions. Can you more fully explain what you are recommending I do?

more options

Did you try Save mode?

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.


If settings aren't kept on a restart then see:

more options

Right I SEE. FF safe mode. I read it as WINDOWS safe mode. Sorry to be dim! I shall try this when I've a bit of time, and get back to report.

more options

Disabling all add ons seems to fix the problem. So - if I disable H/W acceleration how do I check re the graphics display driver? How do I find out what/where my graphic display driver is? Is this a Microsoft piece of S/W, or is it somebody else's?

I'm going to switch safe mode off now...

Back in un-safe mode and the problem has still gone away. But probably temporarily. I'm confused. Does starting in safe mode flush some buffer or other, AS WELL as turning off all add ons?

it's a couple of hours later still and the scrolling issue has not yet returned. I don't see why using safe mode and then turning it off has 'solved' the problem. Any ideas?

Modified by AvisHG

more options

If settings aren't kept on a restart then see:

   https://support.mozilla.com/kb/Preferences+are+not+saved
   http://kb.mozillazine.org/Preferences_not_saved 

I presume this is appertaining to the check box for open a new window in a new tab issue I raised?

My problem is that to all intents and purposes the correct box to make this happen automatically IS checked as FF is started up. FF just doesn't take any notice of it until I go to Tools>Options and then UNCHECK the already CHECKED box and then RECHECK it and save. This seems like a bug to me because it's so weird.

more options

Try to delete the file prefs.js and a possible user.js in the Firefox Profile Folder or move them elsewhere as a test to see if that helps. Some prefs may be corrupted. You will have to redo all pref changes made in Options.

more options

Not just Vista! I'm having the same problem with FF 7.0.1 in Win XP. I decreased max connections to 30, and will try starting in safe mode - but if add-ons have to be disabled that really decreases functionality/customizability of FF.