Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot load websites after a while

  • 4 replies
  • 8 have this problem
  • 28 views
  • Last reply by yeewliang

more options

Firefox can't connect to websites after a while. It will keep on connecting but no results. Sometimes, the page will manage to load. Other times, I need to restart the browser.

Things I have tried: 1. Disable plugins and add-ons. 2. Other browser (Chrome) is working fine.

Chosen solution

The default of the pref network.http.max-connections has been increased from 30 to 256 in Firefox 6+ versions.

Try to decrease the value of the pref network.http.max-connections from 255 to a setting like 30 as used in Firefox 3 versions.

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

The default of the pref network.http.max-connections has been increased from 30 to 256 in Firefox 6+ versions.

Try to decrease the value of the pref network.http.max-connections from 255 to a setting like 30 as used in Firefox 3 versions.

more options

I've tried it but it still doesn't work. Actually, the browser is still working 2 weeks ago. I'm not sure what causes the problem as I didn't update the browser.

Modified by yeewliang

more options

Which beta version of Firefox 8 are you using?

The current version is Firefox 8.0 b3 with buildID 20111011182523. If you use an older version then you should update via Help > About.

Also make sure that you allow Firefox in the firewall.


Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Hey I've tried the earlier method again and this time it seems to work. Thanks!