X
Tap here to go to the mobile version of the site.

Support Forum

How can I download Mozilla Firefox that supports Lightening 1.0beta7

Posted

I have Firefox 3.0.8 installed. I have downloaded the above lightening file but it is not compatible with Firefox 3.0.8. How can I download a newer Firefox edition that will work with Lightening 1.0 beta 7. Albin W. Johnson

I have Firefox 3.0.8 installed. I have downloaded the above lightening file but it is not compatible with Firefox 3.0.8. How can I download a newer Firefox edition that will work with Lightening 1.0 beta 7. Albin W. Johnson

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Default Plug-in
  • Shockwave Flash 10.0 r22
  • McAfee MSC FF plugin DLL
  • SiteAdvisor
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

More Information

Dave G 15 solutions 95 answers

Lightning is an addon for Thunderbird, Mozilla's standalone email client, not Firefox, the web browser.

In any case, the version of Firefox you're using is extremely old and you should update to at least get the latest security and stability fixes. You can install latest Firefox 3.x or latest Firefox 7.

[https://addons.mozilla.org/en-US/thunderbird/addon/lightning/ Lightning] is an addon for [http://www.mozilla.org/en-US/thunderbird/ Thunderbird], Mozilla's standalone email client, not Firefox, the web browser. In any case, the version of Firefox you're using is extremely old and you should update to at least get the latest security and stability fixes. You can install latest [http://www.mozilla.org/en-US/firefox/all-older.html Firefox 3.x] or latest [http://www.mozilla.org/en-US/firefox/fx/ Firefox 7].

Helpful Reply

I installed Moz. FF 7.0.1. On downloading Moz Thunderbird lightening - when I attempted to install it the message came up that Lightening was not compatible with Moz. FF 7.0.1.

Any other suggestions - I am very frustrated.

Albin W. Johnson

I installed Moz. FF 7.0.1. On downloading Moz Thunderbird lightening - when I attempted to install it the message came up that Lightening was not compatible with Moz. FF 7.0.1. Any other suggestions - I am very frustrated. Albin W. Johnson