Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Trying to apply for student loan on fafsa,the site tells me I need an older version of firefox

  • No replies
  • 4 have this problem
  • 9 views
more options

when trying to use the online application to apply for student aid, the fafsa site detects an incompatible version of my browser. Is it possible to download an older version of firefox?

when trying to use the online application to apply for student aid, the fafsa site detects an incompatible version of my browser. Is it possible to download an older version of firefox?