X
Tap here to go to the mobile version of the site.

Support Forum

The awesome bar no longer uses Google's I'm Feeling Lucky feature.

Posted

In earlier versions of firefox, keywords could be typed into the awesome bar and I would be redirected using google's I'm feeling Lucky button. Recently when firefox updates, I have had to go into the about:config page and change keyword.enabled to the link of I'm Feeling Lucky. In the newest update, however, the keyword.enabled string was changed to a boolean value, so I can only enable or disable it rather than change it to I'm Feeling Lucky. Supposedly enabling it will provide the same feature, but I tried a few obvious keywords (Google, Wiki, Hotmail) and all of them came up with a google search instead of redirecting me. I really liked this feature, and I hope there is a way of reimplementing it.

Thanks, ~Casey

In earlier versions of firefox, keywords could be typed into the awesome bar and I would be redirected using google's I'm feeling Lucky button. Recently when firefox updates, I have had to go into the about:config page and change keyword.enabled to the link of I'm Feeling Lucky. In the newest update, however, the keyword.enabled string was changed to a boolean value, so I can only enable or disable it rather than change it to I'm Feeling Lucky. Supposedly enabling it will provide the same feature, but I tried a few obvious keywords (Google, Wiki, Hotmail) and all of them came up with a google search instead of redirecting me. I really liked this feature, and I hope there is a way of reimplementing it. Thanks, ~Casey

Chosen solution

I read somewhere that malware and phishing sites were beginning to misuse the "I'm Feeling Lucky" feature. So it maybe that Mozilla is moving away from auto redirect features that put users at risk.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Nexon Game Controller
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • 4.0.60531.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • YoYoGames InstantPlay XPCOM Plugin for Firefox
  • NPWLPG
  • Provides additional functionality on Facebook. See our web site for details.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

Vivek 289 solutions 2084 answers

Chosen Solution

I read somewhere that malware and phishing sites were beginning to misuse the "I'm Feeling Lucky" feature. So it maybe that Mozilla is moving away from auto redirect features that put users at risk.

I read somewhere that malware and phishing sites were beginning to misuse the "I'm Feeling Lucky" feature. So it maybe that Mozilla is moving away from auto redirect features that put users at risk.

Question owner

Hmm...I understand if they wouldn't want to redirect users to malware sites by default, but I would think they'd still make it an option to users who could cope with the malware. I'll definitely keep looking for a way to use a similar feature, but it's good to know why it was taken away.

Hmm...I understand if they wouldn't want to redirect users to malware sites by default, but I would think they'd still make it an option to users who could cope with the malware. I'll definitely keep looking for a way to use a similar feature, but it's good to know why it was taken away.
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40134 answers

Helpful Reply

You can change that with this pref.

http://kb.mozillazine.org/Keyword.URL

You can change that with this pref. http://kb.mozillazine.org/Keyword.URL

Question owner

Thanks, that fixed it!

Thanks, that fixed it!