X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF opening link in new window instead of new tab

Posted

When I click the option to open a link in a new tab, it opens the link in a new window instead. What's up with that?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • 4.0.60531.0
  • NPWLPG
  • Yahoo Application State Plugin version 1.0.0.7
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • npdnupdater2
  • npdnu
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

Vivek 310 solutions 2084 answers

This usually happens when trying to open the link in a new tab where the link is already coded or set (for example under a site's settings) to open in a new tab. Have you tried clicking directly (left-click) on the link?

Question owner

I did not have this problem until I upgraded to FF 7.0.1.

I did try as you suggested and even tried the open in new window option to see if somehow it was coded backwards.

Thanks.

Vivek 310 solutions 2084 answers

Could be because of an entirely different reason. One last thing that comes to my mind is to try toggling the 'Open new windows in a new ab instead' option under 'Tools' > 'Options' > 'Tabs'.

Question owner

Thanks. I checked that and found that the option to open links in a new tab was ticked - so I unticked it (and all the other options that I had ticked) then clicked OK and it seems to be working now.

TheAntiM 0 solutions 3 answers

Helpful Reply

Since I restarted my computer, Firefox won't open links in tabs. My previous session was restored along with its tabs, but I can't get any new tabs to open via link.

It opens a new (blank) tab, but opens the new page in a separate window. So I don't get the convenience of tabs and I get the added inconvenience of having to close blank tabs when I get back to my home base.

The first thing I did was check the options and I've ticked and unticked the "open in a new tab instead" option several times. Neither way makes the slightest difference.

Any thoughts, anyone?

ETA: After reading something else, I tried Ctrl-Click on links, which does open them in a new tab, but it doesn't automatically switch to that tab... and I have the options set to immediately switch when I click on a new link.

Modified by TheAntiM

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96853 answers

You can check the browser.link.open_newwindow prefs on the about:config page.

There are three prefs, accessible via the about:config page, to control the focus if you click a link.

  • browser.tabs.loadInBackground (normal links)
  • browser.tabs.loadDivertedInBackground (javascript)
  • browser.tabs.loadBookmarksInBackground (bookmarks and searchbar)

See also http://kb.mozillazine.org/about%3Aconfig_entries

TheAntiM 0 solutions 3 answers

Thanks.

mozillauser3 0 solutions 4 answers

Tabs work when I'm in "Safe Mode, add-ons disabled". Is there a quick way to see which add-on is the problem?

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96853 answers

Helpful Reply

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

If you have many extensions then first enable half of the extensions to test which half has the problem.
Continue to divide the bad half that still has the issue until you find which one is causing it.

mozillauser3 0 solutions 4 answers

Thanks. It took awhile but I found the "offender". Nice to have my tabs back.