X
Tap here to go to the mobile version of the site.

Support Forum

Firefox does not save browsing history even though all settings are set up to remember

Posted

Firefox is not remembering my browsing history. I have all the settings set up for Firefox to remember but I keep having to re-enter urls that I use all the time. I had to reformat my hd recently and it remembered just fine prior to the reformat but now it does not remember the history. It goes to the start page but I have to re-enter previous url's that I have visited every time. How do I fix this?

Additionally, under Help/Submit Feedback, neither "Firefox made me happy" nor "Firefox made me sad" options would submit after I tried to enter this problem.

Firefox is not remembering my browsing history. I have all the settings set up for Firefox to remember but I keep having to re-enter urls that I use all the time. I had to reformat my hd recently and it remembered just fine prior to the reformat but now it does not remember the history. It goes to the start page but I have to re-enter previous url's that I have visited every time. How do I fix this? Additionally, under Help/Submit Feedback, neither "Firefox made me happy" nor "Firefox made me sad" options would submit after I tried to enter this problem.

Chosen solution

-> click Firefox button and click Options -> Privacy panel

  • History section -> under Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode
    • place Checkmarks on 1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> 5) Accept Third-party Cookies -> under Keep Until : select They Expire
    • REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES
  • Location Bar section -> under When using the Location bar, suggest select History or History and Bookmarks

-> Click OK on Options window -> Restart Firefox

Check and tell if its working.


-> IF you use Clear Recent History feature, DO NOT select Browsing and Download History item

-> IF you use Privacy Cleanup softwares like CCleaner etc., DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

after a reformat of the hd and re-installation of Firefox.

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Garmin Communicator Plug-In 3.0.1.0
  • Adobe Shockwave for Director Netscape plug-in, version 10.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Office Live Update v1.3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

I am using the most current version of Firefox for PC which is 6.0.2. I have gone back to my settings to confirm that all the boxes relating to saving browsing history are checked and they are.

Hasan 469 solutions 5600 answers

Chosen Solution

-> click Firefox button and click Options -> Privacy panel

  • History section -> under Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode
    • place Checkmarks on 1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> 5) Accept Third-party Cookies -> under Keep Until : select They Expire
    • REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES
  • Location Bar section -> under When using the Location bar, suggest select History or History and Bookmarks

-> Click OK on Options window -> Restart Firefox

Check and tell if its working.


-> IF you use Clear Recent History feature, DO NOT select Browsing and Download History item

-> IF you use Privacy Cleanup softwares like CCleaner etc., DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

-> click '''Firefox''' button and click '''Options''' -> '''Privacy''' panel * '''History''' section -> ''under'' '''Firefox will:''' ''select'' '''"Use Custom Settings for History"''' -> REMOVE Checkmark from '''Permanent Private Browsing mode''' ** place Checkmarks on 1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> 5) Accept Third-party Cookies -> ''under'' '''Keep Until :''' ''select'' '''They Expire''' ** REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES * '''Location Bar''' section -> under '''''When using the Location bar, suggest''''' select '''History''' or '''History and Bookmarks''' -> Click OK on Options window -> Restart Firefox Check and tell if its working. ------------------------------------------------------------------------------------------ -> IF you use '''Clear Recent History''' feature, DO NOT select '''Browsing and Download History''' item * https://support.mozilla.com/en-US/kb/Clear%20Recent%20History#w_what-things-are-included-in-my-history -> IF you use Privacy Cleanup softwares like CCleaner etc., DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

Modified by Hasan

Question owner

I completely forgot to check CCcleaner. I had Firefox checked and every time I went to empty the recycle bin it deleted the history as well as other things.

I completely forgot to check CCcleaner. I had Firefox checked and every time I went to empty the recycle bin it deleted the history as well as other things.