X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I get an error saying I need at least Firefox 3.6 but I have Firefox 3.6.22

Posted

On particular websites, such as 'Words with Friends' on Facebook and Pandora, I get an error saying that my browser is not supported and I need to upgrade. However, I am running the latest version (3.6.22) that can be run on my machine--I have OS X 10.4.11. In 'Words with Friends' I just click 'ok' and it loads, but I can't get Pandora to override the error. I've had this problem for quite awhile now, and I am pretty certain it is some setting on this machine, because the machine I use at work has the same version of OS X and Firefox and does not have the same problem. I have tried reinstalling Firefox to no avail.

Chosen solution

You have user agent that is corrupted by Fast Browser Search and that identifies you as Firefox/3.5.6 FBSMTWB

  • Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 FBSMTWB

See:

Read this answer in context 1

Additional System Details

Sites Affected

http://www.pandora.com/

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • http://www.facebook.com/fbplugin/
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 4.0.60531.0
  • Shockwave Flash 10.3 r183

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 FBSMTWB

More Information

"In order to use Pandora internet radio, please upgrade to a more current browser.
Please check our Help page for more information."
It is interesting that it "guesses" my firefox is 3.5.6, because if that is true, it would solve the problem. But, when I go to Firefox, About Firefox, it says it's 3.6.22. Is there a library file somewhere that needs to be deleted?

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Chosen Solution

You have user agent that is corrupted by Fast Browser Search and that identifies you as Firefox/3.5.6 FBSMTWB

  • Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 FBSMTWB

See:

Question owner

Thanks cor-el! I have one problem though...when I go to the about:config file, it won't let me reset the values--I can only edit them. Any other suggestions? I was able to reset general.useragent.override. I'll see if that fixes things.

Question owner

That worked! I reset general.useragent.override, the rest were already defaulted.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

You're welcome


You can only reset preferences that appear bold (user set). If they are the default then Reset will be grayed to indicate that.