Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens a dialog box when I use the browser, "Checking add-ons for compatibility..." then open the Firefox start page along with my homepage. I do not want the Firefox page when I open the browser. how do I stop this?

  • 1 reply
  • 1 has this problem
  • 39 views
  • Last reply by AliceWyman

more options

Since Firefox updated it checks add-ons every time I open Firefox. The Firefox homepage then opens along with my home page, two tabs. I want the checking to stop. This has not happened before--only with this update.

All Replies (1)

more options

This question was reposted and replied to here:
https://support.mozilla.com/en-US/questions/878953

... so I'll lock this thread.