X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Exc in ev handl: Error: Bad NPObject as private data!

Posted

Every time a new website is accessed

Additional System Details

This happened

Every time Firefox opened

This started when...

after upgrade

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • SiteAdvisor
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

David McRitchie 321 solutions 3089 answers

See

I am getting the following popup when using firfox as my browser: Exc in ev handl: Error: Bad NPObject as private data! | Firefox Support Forum | Firefox Help https://support.mozilla.com/en-US/questions/859076

"uninstalled VLC Media Player (vlc-1.1.11-win32.exe) entirely, from the Windows Control Panel Uninstaller."

David McRitchie 321 solutions 3089 answers

Helpful Reply

new information, as I just had McAfee Site Advisor get updated.

Disable "McAfee Site Advisor" extension which was just updated to 3.4.0, which probably took it out of the addons block list.

  • "Ctrl+Shift+A" > find McAfee Site Advisor and use "Disable", and then restart Firefox.
  • Do a Google Search no problem
  • It seems that if you re-enable Site Advisor again, and restart Firefox you are okay. At least you know where to look if you get the error again or Google searches slow down.
geophil 0 solutions 1 answers

THX @dmcritchie - but i have problems to find his way. These are the steps on german surface: open Mozilla browser, click "Extras" tab; select "Add-ons"; click "Erweiterungen", scroll for and select McAfee SiteAdvisor; click "Deaktivieren", new start Mozilla.

pwatson 0 solutions 9 answers

I had to disable the McAfee SiteAdvisor in BOTH Extensions and Plugins. After doing that and restarting FireFox, I do not experience the problem.

Modified by pwatson

nhng2000 0 solutions 1 answers

I might sound naive, could you please advise how I access to McAfee adviser so I can disable, as suggested please

David McRitchie 321 solutions 3089 answers

Helpful Reply

  1. Bring up add-ons, any of these methods
    • "Ctrl+Shift+A"
    • Tools > Options > Add-ons
    • "Firefox" button > Options > Add-ons
    • "Firefox" button > Options (drop-down) > Options > Add-ons
  2. Left side of add-ons choose "Extensions" (puzzle piece)
  3. Click on "Disable" button at the extension's name ("McAfee Site Advisor")

And I'd never noticed before but as PWatson indicated it is also a plug-in

  1. same as above
  2. same as above
  3. Left side of add-ons choose "Plugins" (like a blue lego piece)
  4. Click on "Disable" button at the plug-ins name ("McAfee Site Advisor")

I tried disabling just the plug-in as a test, and I immediately got the message, so it is the lack of the plug-in that is the problem and though disabling was immediate it took restarting Firefox to to activate the plug-in properly, and why restarting Firefox works. But probably also why McAfee support people indicated to uninstall the Extension and uninstall the program through the control panel, restart Windows and reinstall the extension from siteadvisor,com to make sure everything functions properly the extension and plug-in have different numbers..

karea 0 solutions 1 answers

I am having the same problem but i dont think it has anything to do with my VLC player or my McAfee cause the top of the popup box says java scrpit application error. and it is irritating me cause it keeps making my tabs into new windows

MrViklund 0 solutions 1 answers

Well. This problem started for me yesterday. Dec 10. I followed the solution provided by "dmcritchie" and it works. According to Firefox, McAfee Site Advisor updated on Dec 10 and my problems started that day. I just disabled it and restarted Firefox. It's sad though, McAfee Site Advisor is a good plugin so I hope they fix this problem soon. Allot of people use McAfee Site Advisor.

bertv 0 solutions 1 answers

I had this problem too after I disabled the McAfee Advisory Site plug-in. I solved it by completely uninstalling the software. Go to "Control Panel"; open "Programs and Features"; highlight McAfee Advisory and click "uninstall".

elyodmk 0 solutions 1 answers

Thanks for the tip. Disabling McAfee site advisor seems to work like a charm.