X
Tap here to go to the mobile version of the site.

Support Forum

javascript:navigator.registerProtocolHandler(‘mailto’,’http://mail.live.com/secure/start?action=compose&to=%s','Windows Live Mail’); Why doesn't this work so i can set firefox to recognise web mailto links

Posted

Why doesn't this link work so i can set firefox to recognize web mailto links?

javascript:navigator.registerProtocolHandler(‘mailto’,'http://hotmail.msn.com/secure/start?action=compose&to=%s’,'Hotmail’);

Why doesn't this link work so i can set firefox to recognize web mailto links? javascript:navigator.registerProtocolHandler(‘mailto’,'http://hotmail.msn.com/secure/start?action=compose&to=%s’,'Hotmail’);

Additional System Details

This happened

Every time Firefox opened

This started when...

when i try to set firefox to recognize web mailto links such as Hotmail, since hotmail is my main email handler.

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Picasa plugin
  • 4.0.60531.0
  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

Did you first enable that command by setting the pref gecko.handlerService.allowRegisterFromDifferentHost to true on the about:config page ?

Do not forget to reset the pref gecko.handlerService.allowRegisterFromDifferentHost to false after you have added Hotmail.

Did you first enable that command by setting the pref <b>gecko.handlerService.allowRegisterFromDifferentHost</b> to true on the about:config page ? Do not forget to reset the pref gecko.handlerService.allowRegisterFromDifferentHost to false after you have added Hotmail.

Question owner

Yes i did set it to true but to no avail.

Yes i did set it to true but to no avail.
cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

Did you check if that makes Windows Live available as a choice for mailto in Tools > Options > Applications ?

Did you check if that makes Windows Live available as a choice for mailto in Tools > Options > Applications ?
jkkw 0 solutions 1 answers

this worked as recently as 7.0, but in 7.01 i can't get javascript:navigator.registerProtocolHandler to work with any mailto: targets. Did this break in 7.01?

this worked as recently as 7.0, but in 7.01 i can't get javascript:navigator.registerProtocolHandler to work with any mailto: targets. Did this break in 7.01?
cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

Helpful Reply

In Firefox 6 you can no longer run JavaScript code via the location bar.

See:

Set the pref gecko.handlerService.allowRegisterFromDifferentHost to true on the about:config page.

You need to create a new bookmark (e.g. on the Bookmarks Toolbar) and paste the full code including javascript: to the location field of that bookmark.

Click that bookmark to run the code and confirm that you want to add the new mailto provider.

Do not forget to reset the pref gecko.handlerService.allowRegisterFromDifferentHost to false after you have added that mail provider.

In Firefox 6 you can no longer run JavaScript code via the location bar. See: *[[/questions/871548]] Set the pref gecko.handlerService.allowRegisterFromDifferentHost to true on the about:config page. You need to create a new bookmark (e.g. on the Bookmarks Toolbar) and paste the full code including javascript: to the location field of that bookmark. Click that bookmark to run the code and confirm that you want to add the new mailto provider. Do not forget to reset the pref gecko.handlerService.allowRegisterFromDifferentHost to false after you have added that mail provider.
somehelp 0 solutions 4 answers

I have followed this procedure on Firefox 8.0 running windows 7 and can't get it to work. I don't get the popup to "add hotmail" or "add application" and the hotmail entry isn't in the drop down list in applications either after doing the "about:config" then entering "gecko" entry in the filter field and changing the false to true etc.

Is it possible to make this work in Firefox 8.0 and if not should I download an older version so I can do this procedure and if so what version would work? I'm interested in using the "mail to" reply links like in Craigs list and can't seem to find out how to add hotmail to the drop down so I don't have to copy and paste the "mail to" links in the ads into a hotmail email to send them.

Thanks for any help in getting hotmail to be the default email.

I have followed this procedure on Firefox 8.0 running windows 7 and can't get it to work. I don't get the popup to "add hotmail" or "add application" and the hotmail entry isn't in the drop down list in applications either after doing the "about:config" then entering "gecko" entry in the filter field and changing the false to true etc. Is it possible to make this work in Firefox 8.0 and if not should I download an older version so I can do this procedure and if so what version would work? I'm interested in using the "mail to" reply links like in Craigs list and can't seem to find out how to add hotmail to the drop down so I don't have to copy and paste the "mail to" links in the ads into a hotmail email to send them. Thanks for any help in getting hotmail to be the default email.

Modified by somehelp

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

Did you create a bookmark with the javascript code?

javascript:navigator.registerProtocolHandler("mailto","http://hotmail.msn.com/secure/start?action=compose&to=%s","Hotmail");
Did you create a bookmark with the javascript code?<br /> <br /> <pre><nowiki>javascript:navigator.registerProtocolHandler("mailto","http://hotmail.msn.com/secure/start?action=compose&to=%s","Hotmail");</nowiki></pre>
somehelp 0 solutions 4 answers

Yes, I used that same link you posted including substituting the " for ' and I still didn't get the pop up for "adding hotmail"

I even tried it with the double quotes too and nothing. No drop down saying "add hotmail".

Yes, I used that same link you posted including substituting the " for ' and I still didn't get the pop up for "adding hotmail" I even tried it with the double quotes too and nothing. No drop down saying "add hotmail".

Modified by somehelp

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

Helpful Reply

The JavaScript code also works for me if I paste it in the Firefox > Web Developer > Scratchpad (Shift + F4) and issue Execute > Run


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

The JavaScript code also works for me if I paste it in the Firefox > Web Developer > Scratchpad (Shift + F4) and issue Execute > Run ----- Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode
somehelp 0 solutions 4 answers

Thanks very much. I did it as you recommended and got the drop down this time that I wasn't getting before and Hotmail is installed now in the mailto drop down now.

I can't thank you enough!!!!

Do I have to do the "about:config" and the "gecko" operation and change the "true" back to "false" now ?

Thanks very much. I did it as you recommended and got the drop down this time that I wasn't getting before and Hotmail is installed now in the mailto drop down now. I can't thank you enough!!!! Do I have to do the "about:config" and the "gecko" operation and change the "true" back to "false" now ?

Modified by somehelp

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

You're welcome


Quote: Do I have to do the "about:config" and the "gecko" operation and change the "true" back to "false" now ?

Yes.

You're welcome ---- Quote: ''Do I have to do the "about:config" and the "gecko" operation and change the "true" back to "false" now ? '' Yes.

Modified by cor-el

somehelp 0 solutions 4 answers

Thanks again!

Just curious here about this action. What would happen if I left it at "true"?

I already changed it back to "false" just now and it dropped down in the list about 6 positions instead of being the first entry like the text said it would be. Is this Normal?

Thanks again.

Thanks again! Just curious here about this action. What would happen if I left it at "true"? I already changed it back to "false" just now and it dropped down in the list about 6 positions instead of being the first entry like the text said it would be. Is this Normal? Thanks again.

Modified by somehelp

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157383 answers

If that setting is true then maybe websites are able to register a protocol, but I'm not sure about that.


It is possible that you are sorting entries via another column the Status or Value column that changed its value. Best is to sort for name by clicking the Preference Name header.

If that setting is true then maybe websites are able to register a protocol, but I'm not sure about that. *https://developer.mozilla.org/en/Web-based_protocol_handlers ---- It is possible that you are sorting entries via another column the Status or Value column that changed its value. Best is to sort for name by clicking the Preference Name header.