Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I can't use some plug-ins and personna, and want to go back to 3.6

more options

some of my plug-ins and extensions and the harley davidson personna will not work, so I want to go back to 3.6--I liked the look and how it worked. Thank You, Steve Cutler

All Replies (2)

more options

Chosen Solution

more options

Thank You, as system restore to the previous week was not working, and could not find 3.6.12 in my system... I had found it at firefox site, but was not sure of the complete ramifications of just downloading it. Thanks again, Steve Cutler