X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since updating Firefox automatically to 6.0.1 facebook.com does not display the "wall"

Posted

facebook.com displays and I can log on but the page does not display correctly. It appears to have the "wall" section missing. I have cleared my cache and cookies with no change. I can open facebook.com correctly from within IE9.

Chosen solution

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

Read this answer in context 1

Additional System Details

Sites Affected

http://www.facebook.com

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

Application Basics
Name
Firefox
Version
6.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.3.9
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
DownloadHelper
4.9.5
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
English (Australian) Dictionary
2.1.2
true
en-AU@dictionaries.addons.mozilla.org
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com.au/
browser.startup.homepage_override.buildID
20110830092941
browser.startup.homepage_override.mstone
rv:6.0.1
extensions.lastAppVersion
6.0.1
font.minimum-size.x-western
14
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1314916329
places.history.expiration.transient_current_max_pages
256423
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTX 470
Vendor ID
10de
Device ID
06cd
Adapter RAM
1280
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.6658
Driver Date
1-7-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows
2/2 Direct3D 10

reddpigg 0 solutions 1 answers

Selecting "Place marker after inputs" option of InFormEnter add-on caused my problem.

Question owner

Sorry reddpigg - no go for me. Seems like there's a few others with similar issue though since the update.

Question owner

Something to note for anyone trying to resolve this - The facebook "message" page seems to display correctly when I have a message selected.

Question owner

Updating to 6.0.2 did not resolve this issue. :(

Does anyone know if Firefox developers monitor these forums? I think this issue will need some changes to the program as it only started with the update.

dkkaw 0 solutions 1 answers

have the same problem, FF 6.0.2 and facebook only displays links, and most of those don't work. I've cleared everything, reset everything, safemode, etc, but nothing. Using an Intel Mac here. FB loads fine on safari though.

Question owner

Not sure how or why but when I've just visited facebook.com it is displaying correctly now (???) All good for me. I hope the other people with this issue now have it resolved. Cheers

Question owner

Hmm...Guess I spoke too soon. Its not working again! :( Same thing: only displays the outside frames and seems to shift all the frames right excluding the "wall" frame.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Helpful Reply

Thanx cor-el for the great reply. Results:

- Reload web page and bypass the cache = no change

- Clear the Cache = no change

- Remove cookies = no change

- Start Firefox in Safe Mode = Success!!!

I then went and disabled each of the extensions individually and it still didn't work. What else does "Safe Mode" change? If I've disabled each of the extensions individually and checked each time and I use the default theme then it's not either of those things. So Safe Mode must change something else too.

Question owner

Thanx cor-el for the great reply. Results:

- Reload web page and bypass the cache = no change

- Clear the Cache = no change

- Remove cookies = no change

- Start Firefox in Safe Mode = Success!!!

I then went and disabled each of the extensions individually and it still didn't work. What else does "Safe Mode" change? If I've disabled each of the extensions individually and checked each time and I use the default theme then it's not either of those things. So Safe Mode must change something else too.

whofan 0 solutions 1 answers

That fix worked for me as well!

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Chosen Solution

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

Helpful Reply

Ok so we've now identified the issue. When I switch hardware acceleration off and restart Firefox, facebook.com displays correctly.

I have an nVidia 470 GTX which I updated to the latest drivers available from nVidia (released 3rd August 2011) and enabled hardware acceleration. The issue returns.

I'm not sure if the issue is with Firefox and how it uses hardware acceleration in 6.0.1 and above or if nVidia needs to update it's drivers. A bit of both I suspect.

At least for now I can simply disable hardware acceleration until a fix is released. I'm not even sure if I use the hardware acceleration for anything. Maybe Flash videos I suppose but other than that I'm not sure.

Hope cor-el's fix works for others.

Thanks cor-el :)