X
Tap here to go to the mobile version of the site.

Support Forum

Even though the "browser.ShowQuitWarning" is set to yes, firefox just immediately closes when I go to close it, and doesn't show the Save on Quit warning

Posted

I have tried toggling the yes/no for the browser.showQuitWarning on about:config

My current addons are: Bartab, Download Status Bar, Flashblock, Google Music Downloader, Movable Firefox Button, and Read it Later. Thanks!

I have tried toggling the yes/no for the browser.showQuitWarning on about:config My current addons are: Bartab, Download Status Bar, Flashblock, Google Music Downloader, Movable Firefox Button, and Read it Later. Thanks!

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.9
  • Version 2.2.2.0
  • Google Update
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • DivX Web Player version 2.1.0.900
  • DivX VOD Helper Plug-in
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • BlackBerry WebSL Browser Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16648 solutions 150459 answers

Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"
Make sure that you do not run Firefox in permanent Private Browsing mode. *https://support.mozilla.com/kb/Private+Browsing *You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" *To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Deselect: [ ] "Permanent Private Browsing mode"

Question owner

Thanks for the reply! Unfortunately, that's not the problem, as I have it set to remember history. Thanks again

Thanks for the reply! Unfortunately, that's not the problem, as I have it set to remember history. Thanks again
cor-el
  • Top 10 Contributor
  • Moderator
16648 solutions 150459 answers

Firefox 4 and later versions save the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
Use "File > Exit" or "Firefox > Exit" (Mac: "Firefox > Quit Firefox") if you want to restore multiple windows.
You can use "History > Restore Previous Session" to get the previous session at any time.
You may need to click the orange/gray Firefox button to see History.
There is also a "Restore Previous Session" button on the default about:home Home page.

Another possibility is to use:

Firefox 4 and later versions save the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.<br /> Use "File > Exit" or "Firefox > Exit" (Mac: "Firefox > Quit Firefox") if you want to restore multiple windows.<br /> You can use "History > Restore Previous Session" to get the previous session at any time.<br /> You may need to click the orange/gray Firefox button to see History.<br /> There is also a "Restore Previous Session" button on the default <b>about:home</b> Home page. Another possibility is to use: * [http://kb.mozillazine.org/Menu_differences Firefox/Tools > Options] > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"
blauvogel 0 solutions 1 answers

Helpful Reply

Thanks for the reply, I think all of us do not struggle with restoring our sessions, which now happens automatically as you correctly point out. The issue rather is that this AUTOMATIC behavior is not always wanted: I would rather have Firefox ask me upon quitting if indeed I wish the session to be restored the next time so that I may choose "NO" (and start with a blank session next time) or "YES" depending on the situation at hand. Until FF 6.0.1 the browser.showQuitWarning boolean did the job, but now seems to be ignored.

Thanks for the reply, I think all of us do not struggle with restoring our sessions, which now happens automatically as you correctly point out. The issue rather is that this AUTOMATIC behavior is not always wanted: I would rather have Firefox ask me upon quitting if indeed I wish the session to be restored the next time so that I may choose "NO" (and start with a blank session next time) or "YES" depending on the situation at hand. Until FF 6.0.1 the browser.showQuitWarning boolean did the job, but now seems to be ignored.

Modified by blauvogel

dither 0 solutions 1 answers

Beyond the asking if I want to save my tabs, I find the warning box to be highly useful when I accidentally hit Command + Q on my mac.. when I was intending to hit Command + W (which is right next to Q) or Command + Tab (also next to Q). I liked that if I accidentally hit the Q, it would ask me before quitting.

Beyond the asking if I want to save my tabs, I find the warning box to be highly useful when I accidentally hit Command + Q on my mac.. when I was intending to hit Command + W (which is right next to Q) or Command + Tab (also next to Q). I liked that if I accidentally hit the Q, it would ask me before quitting.
cor-el
  • Top 10 Contributor
  • Moderator
16648 solutions 150459 answers

I recently came across this method to change that command to Shift+Ctrl+Q.

defaults write NSGlobalDomain NSUserKeyEquivalents '{"Quit Firefox" = "@$Q";}'
I recently came across this method to change that command to Shift+Ctrl+Q. *[[/questions/783393]] *http://www.mactipper.com/2008/03/add-keyboard-shortcuts-for-applications.html defaults write NSGlobalDomain NSUserKeyEquivalents '{"Quit Firefox" = "@$Q";}'
nightowl12 0 solutions 2 answers

Helpful Reply

Don't forget the "browser.warnOnQuit" setting.

I also had this problem. Check your 'Startup' setting in Options > General. If it is set to "Show my windows and tabs from last time", then toggling the 'warning' settings won't make a difference.

Set it to "Show my home page" and you'll get the familiar message again.

Don't forget the "browser.warnOnQuit" setting. I also had this problem. Check your 'Startup' setting in Options > General. If it is set to "Show my windows and tabs from last time", then toggling the 'warning' settings won't make a difference. Set it to "Show my home page" and you'll get the familiar message again.