X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox doesn't remember username and password

Posted

Just installed firefox in a new Lenovo laptop with Windows 7. Firefox is not asking to save password for sites. I have checked all the proper tabs and all is ok. I have the business Lenovo laptop with W7 as well, same firefox, and works well there.

Noticed also that Slingbox application on installation is supposed to show a yellow bar asking permission to install a driver (or something like that), it is not happening and stuck there waiting for input.

It looks like the requests pop ups are no happening on this new pc.

I am sure the options/security/remember pass is checked and the options/privacy is not set to clear passwords

Additional System Details

This happened

Every time Firefox opened

This started when...

new installation 6.0 or 6.0.1 on Windows 7

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

Application Basics
Name
Firefox
Version
6.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.22
false
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Java Console
6.0.24
false
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Java Console
6.0.26
false
{CAFEEFAC-0016-0000-0026-ABCDEFFEDCBA}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://att.my.yahoo.com
browser.startup.homepage_override.buildID
20110830092941
browser.startup.homepage_override.mstone
rv:6.0.1
browser.tabs.warnOnClose
false
dom.disable_open_during_load
false
extensions.lastAppVersion
6.0.1
gfx.blacklist.webgl.angle
3
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1314579583
places.history.expiration.transient_current_max_pages
382999
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
NVIDIA Quadro 1000M
Vendor ID
10de
Device ID
0dfa
Adapter RAM
2048
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.6802
Driver Date
4-1-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17514)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
NVIDIA Corporation -- Quadro 1000M/PCI/SSE2 -- 4.1.0
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"

You no longer get a yellow bar at the top.
Firefox 4 and later versions place a key icon on the location bar that allows to (re)open the dialog to save the password at any time.
That pop-up dialog has a button labeled with "Remember Password".
If you click the arrow next to that button then you see the other choices ("Never Remember Password for this site", "Not Now").

Question owner

I did check already all the setting above, they all are correct. Also, I see the key icon, but the pop up dialog does not appear.

It looks like somehow windows 7 is preventing a pop up dialog of any type, including asking if I want to save password. In another application, the application is getting stuck at the point where i am supposed to see the pop up request permission to install (active-x), but it doesn't happen. This is a brand new PC, W7 went though several updates during setup. At one point i was getting the pop up permission dialogs, then it stopped. Any clue to check in W7?

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


See also Troubleshooting:

Question owner

Yes, it works when I start in safe mode, I get the pop up request for remembering password. How do I know now what to remove? Something is causing a problem.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Question owner

Thanks. I did disabled all add-ons (checked box in the safe mode window) and restarted, but not improvement. I then entered again safe mode and checked all five boxes, then Make changes and Restart. Still not working. The only way i get the password remember question pop up is if I start firefox in safe mode. Something else is making it work in safe mode.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Also check:


Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Question owner

Well, tried this one too. I created a new profile, started firefox with that profile selected, the first time i open a page with a username/password input, firefox pop up balloon asking to save password showed up, momentarily while application page was loading, then disappeared without me clicking anything. Password was not saved. I tried again, but all the times after this, no work. I deleted the profile, and the files, and then the default one with its files, create a new default profile, and still not working. Only way it is working is to restart in safe mode. Wow..

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Did you make sure that there weren't any extension installed in that new profile that Firefox may have sound via a registry scan?


Do a malware check with some malware scanning programs.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

See also:

Question owner

The only thing I see in Extensions are three Java Consoles 6.0.22 6.0.24 and 6.026, but they are disabled. It says Java console incompatible with Firefox 6.0.2. I assume disabled should not create a problem. If it does, how to I remove them, there is not button to remove.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You can remove the Java Console extensions.

See:

Question owner

Removed the Java extensions.. now it is empty.. restarted, same problem.. What else can be that it works in safe mode and not in normal mode?

Question owner

BTW, this is a brand new Lenovo, did not download any weird stuff, etc., except for Quicken and MS Office.

eriktorbjorn 0 solutions 1 answers

Helpful Reply

I had the same problem. Strangely enough, what finally helped for me was to select "Tools > Options > Advanced", and disable the "Use hardware acceleration when available" option.

culhwch 0 solutions 1 answers

Disabling "Use hardware acceleration when available" worked for me, too.