X
Tap here to go to the mobile version of the site.

Support Forum

Fonts totally messed up on some sites

Posted

Since upgrading to 6.0, some sites can't be read at all. Instead of regular fonts, there are symbol fonts. Below is only one example. It doesn't happen on every site, only some. I've tried everything on the support page for "web pages not loading properly" (or whatever it's called). Could it be a plug-in problem?

Since upgrading to 6.0, some sites can't be read at all. Instead of regular fonts, there are symbol fonts. Below is only one example. It doesn't happen on every site, only some. I've tried everything on the support page for "web pages not loading properly" (or whatever it's called). Could it be a plug-in problem?

Additional System Details

Sites Affected

https://www.richters.com/Web_store/display.cgi?page=./Html/delivery_details_form.html&cart_id=9793472.17465

Installed Plug-ins

  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Web Player version 1.4.0.233
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

I've run Disk Utility & reloaded affected pages, but no change.

David McRitchie 320 solutions 3092 answers

What were you trying to do -- post a picture? I think we could answer your question better if you just posted the url, and described the symbols you got, what you expected and where to look.

If everything is really messed make sure in Tools > Options > Content > fonts Advanced that you have Western (ISO-8859-15) for default character encoding.

The symbols used in Microsoft documents wingdings, webdings are Microsoft fonts are not available in browsers other than IE (webdings was supposed to be public but Microsoft goofed in contracting work out). Mozilla exacerbated the problem by choosing an obscure Adobe font for symbols, now all browsers can make better use of Unicode fonts and such documents should be rewritten. If you are looking at vertical rectangles with hex code within it is showing the value for the character that you have not included in your fonts, possibly because of the font-size or other font attributes.

What were you trying to do -- post a picture? I think we could answer your question better if you just posted the url, and described the symbols you got, what you expected and where to look. If everything is really messed make sure in Tools > Options > Content > fonts Advanced that you have Western (ISO-8859-15) for default character encoding. The symbols used in Microsoft documents wingdings, webdings are Microsoft fonts are not available in browsers other than IE (webdings was supposed to be public but Microsoft goofed in contracting work out). Mozilla exacerbated the problem by choosing an obscure Adobe font for symbols, now all browsers can make better use of Unicode fonts and such documents should be rewritten. If you are looking at vertical rectangles with hex code within it is showing the value for the character that you have not included in your fonts, possibly because of the font-size or other font attributes.

Modified by David McRitchie

finitarry 251 solutions 3421 answers

You could try switching character codes from View > Character Encoding. I tried that order form whose page you listed in your detailed description, and it looked normal to me. My Firefox defaulted to Unicode (UTF-8) to display it, but Western (ISO-8859-1) worked just as well.

You could try switching character codes from View > Character Encoding. I tried that order form whose page you listed in your detailed description, and it looked normal to me. My Firefox defaulted to Unicode (UTF-8) to display it, but Western (ISO-8859-1) worked just as well.

Question owner

I was trying to place an order. The url I posted is just one that does this. had Western ISO-8859-1, so I tried changing it to 15 but still no change. I'm on a Mac; don't use Microsoft at all. The symbols are all musical. I tried copying one line, but when I included it in my message, it pasted with proper fonts!

I was trying to place an order. The url I posted is just one that does this. had Western ISO-8859-1, so I tried changing it to 15 but still no change. I'm on a Mac; don't use Microsoft at all. The symbols are all musical. I tried copying one line, but when I included it in my message, it pasted with proper fonts!

Question owner

Thank-you, too, finitarry. I changed the encoding to UTF-8 & still no change. I didn't restart Firefox -- perhaps I should,

Thank-you, too, finitarry. I changed the encoding to UTF-8 & still no change. I didn't restart Firefox -- perhaps I should,
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156049 answers

You can do a check for corrupted fonts and other font issues:

You can do a check for corrupted fonts and other font issues: * http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts

Question owner

cor-el: It's not my fonts that are corrupted. It has something to do with certain websites and Firefox 6.0 or add-ons or plugins. I haven't used Font Book for years.

cor-el: It's not my fonts that are corrupted. It has something to do with certain websites and Firefox 6.0 or add-ons or plugins. I haven't used Font Book for years.
David McRitchie 320 solutions 3092 answers

"I think we could answer your question better if you just posted the url" -- 18 hours ago

"I think we could answer your question better if you just posted the url" -- 18 hours ago

Question owner

Here is just one url (BTW, I did post it with my original question.) You'll see above that finitarry tried it & it was fine for him/her. I also see now that two other people have the same problem.

https://www.richters.com/Web_store/display.cgi?page=./Html/delivery_details_form.html&cart_id=9793472.17465

Thank-you!

Here is just one url (BTW, I did post it with my original question.) You'll see above that finitarry tried it & it was fine for him/her. I also see now that two other people have the same problem. https://www.richters.com/Web_store/display.cgi?page=./Html/delivery_details_form.html&cart_id=9793472.17465 Thank-you!

Modified by janeisgreen

finitarry 251 solutions 3421 answers
http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Question owner

Thanks for that, finitarry. My particular font rendering problem isn't there (being replaced by a music font), but I tried the FontNuke app., restarted, and -- still nothing! :( I also e-mailed creativetechs.com with my particular rendering problem.

Thanks for that, finitarry. My particular font rendering problem isn't there (being replaced by a music font), but I tried the FontNuke app., restarted, and -- still nothing! :( I also e-mailed creativetechs.com with my particular rendering problem.
Pywakket 0 solutions 4 answers

Helpful Reply

Yep. Same problem. It isn't just one url, it's several. Most sites I'm unable to post replies, comments, etc. My fonts are working fine in Safari and all my other programs, so it isn't a corrupt font. I'm on a Mac using 10.6.8. I'm frustrated enough to stop using Firefox and just switching to Safari. I had to switch to Safari to make all the reservations for my upcoming vacation and also to pay most of my bills.

Yep. Same problem. It isn't just one url, it's several. Most sites I'm unable to post replies, comments, etc. My fonts are working fine in Safari and all my other programs, so it isn't a corrupt font. I'm on a Mac using 10.6.8. I'm frustrated enough to stop using Firefox and just switching to Safari. I had to switch to Safari to make all the reservations for my upcoming vacation and also to pay most of my bills.

Question owner

Pywakkat: Exactly the same OS 10.6.8; new Firefox 6.0. I haven't even tried with Safari but I guess I should. I haven't used it in years so my bookmarks, etc., aren't there. Darnit! I've always trusted Firefox!

Pywakkat: Exactly the same OS 10.6.8; new Firefox 6.0. I haven't even tried with Safari but I guess I should. I haven't used it in years so my bookmarks, etc., aren't there. Darnit! I've always trusted Firefox!

Question owner

Works fine on Safari - definitely a Firefox 6.0 issue!

Works fine on Safari - definitely a Firefox 6.0 issue!
Pywakket 0 solutions 4 answers

Helpful Reply

Yep. I've been using Firefox for years, don't like Safari. This is driving me nuts. Just tried tracking an order and I couldn't enter the stupid info for tracking. Had to copy the url and paste it into Safari.

Sure hope they think we're important enough to address this issue. It seems like a widespread problem when you look it up on Google.

Yep. I've been using Firefox for years, don't like Safari. This is driving me nuts. Just tried tracking an order and I couldn't enter the stupid info for tracking. Had to copy the url and paste it into Safari. Sure hope they think we're important enough to address this issue. It seems like a widespread problem when you look it up on Google.
Pywakket 0 solutions 4 answers

Meant to add, I was a little miffed at the response you received asking for the url. Your original post said "several sites". "Were you trying to post a picture?" Where did that come from?

Meant to add, I was a little miffed at the response you received asking for the url. Your original post said "several sites". "Were you trying to post a picture?" Where did that come from?
finitarry 251 solutions 3421 answers

I am also using FF 6 and on Mac OS 10.6.8, and had no problem with that order form page, and have had no problems with fonts on other sites. It may be an issue with the Firefox profile. Try the Standard Diagnostic from here:

I am also using FF 6 and on Mac OS 10.6.8, and had no problem with that order form page, and have had no problems with fonts on other sites. It may be an issue with the Firefox profile. Try the Standard Diagnostic from here: * http://kb.mozillazine.org/Standard_diagnostic_%28Firefox%29
Pywakket 0 solutions 4 answers

Thanks, but none of that helped. Oddly enough, most of the pages on the mozilla site had the same problem! I reinstalled an older version. That fixed it. I'll keep running the older version until I have the time to copy everything to Safari.

Thanks, but none of that helped. Oddly enough, most of the pages on the mozilla site had the same problem! I reinstalled an older version. That fixed it. I'll keep running the older version until I have the time to copy everything to Safari.
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156049 answers

Did you do a font check in Font Book?

Other programs may react differently if a font isn't working.

Did you do a font check in Font Book? Other programs may react differently if a font isn't working.

Question owner

I've done everything that's been recommended by you good folks, but nothing has helped. I see there's a Firefox update -- we'll see if that helps. I'll let you know tomorrow.

I've done everything that's been recommended by you good folks, but nothing has helped. I see there's a Firefox update -- we'll see if that helps. I'll let you know tomorrow.

Question owner

Nope, the update made no difference!

Nope, the update made no difference!