Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need 3.5x & 3.6x versions to do my FAFSA application. How do I get them?

  • No replies
  • 4 have this problem
more options

FAFSA application requires an older version of Firefox, how do I find it? I am so tired of downloading these different browsers that don't work on FAFSA! FAFSA told me that this site had some way of reconsiling this, but I can't figure it out. Please help.