X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

npLegitCheckPlugin.dll and/or nsILegitCheckPlugin.xpt corrupted, how to obtain and replace.

Posted

tried to open fire fox before computer power up completed. now windows validation fails. running XP

Additional System Details

Installed Plug-ins

  • 1.9.0042.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • 4.0.60310.0
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

David Tenser
  • Administrator
  • Moderator
32 solutions 294 answers

Helpful Reply

Please reinstall Firefox by downloading it again from mozilla.org. It should take care of this problem. Please post back here if it doesn't.

alimohamadi 0 solutions 1 answers

Helpful Reply

nsILegitCheckPlugin.xpt