X
Tap here to go to the mobile version of the site.

Support Forum

After update to 3.6.20, ERROR, platform version 1.9.2.18 not compatible with Min/Max v 1.9.2.20

Posted

Win2000 Pro SP4. Been running FireFox for several years. Ver3.6.6 since 03/22/2011. Got a msg window in FireFox stating important security update available. (ADDED INFO: Checked System Requirements of update and then...) As usual, I clicked yes load it. A few moments later I got the message: "XULRunner Error: Platform version '1.9.2.18' is not compatible with minVersion>=1.9.2.20 maxVersion<=1.9.2.20" That is it, NO MORE FIREFOX!!! How can I fix it and not loose any of my 'stuff'?

Win2000 Pro SP4. Been running FireFox for several years. Ver3.6.6 since 03/22/2011. Got a msg window in FireFox stating important security update available. ''(ADDED INFO: Checked System Requirements of update and then...)'' As usual, I clicked yes load it. A few moments later I got the message: "XULRunner Error: Platform version '1.9.2.18' is not compatible with minVersion>=1.9.2.20 maxVersion<=1.9.2.20" That is it, NO MORE FIREFOX!!! How can I fix it and not loose any of my 'stuff'?

Modified by GaaDoo

Chosen solution

The updater wasn't able to update all the files and some were left as older versions.
Do a clean reinstall.

Download a fresh Firefox copy and save the file to the desktop.

  • Uninstall your current Firefox version.
  • Do not remove personal data when you uninstall the current version.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

Updated (see Details).

Installed Plug-ins

None that I am aware of??

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

More Information

None (see Details)

cor-el
  • Top 10 Contributor
  • Moderator
17177 solutions 155254 answers

Chosen Solution

The updater wasn't able to update all the files and some were left as older versions.
Do a clean reinstall.

Download a fresh Firefox copy and save the file to the desktop.

  • Uninstall your current Firefox version.
  • Do not remove personal data when you uninstall the current version.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

The updater wasn't able to update all the files and some were left as older versions.<br /> Do a clean reinstall. Download a fresh Firefox copy and save the file to the desktop. * Firefox 6.0.x: http://www.mozilla.com/en-US/firefox/all.html * Uninstall your current Firefox version. * Do not remove personal data when you uninstall the current version. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. * It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

Question owner

cor-el, Thank you very much. Great step-by-step and detail. It worked perfect. I installed 3.6.20 complete, from scratch. No problems! Thank you again, Hovy

cor-el, Thank you very much. Great step-by-step and detail. It worked perfect. I installed 3.6.20 complete, from scratch. No problems! Thank you again, Hovy
cor-el
  • Top 10 Contributor
  • Moderator
17177 solutions 155254 answers

Helpful Reply

You're welcome

You're welcome
justjo 0 solutions 2 answers

I have the same problem. Message says "ERROR, platform version 1.9.2.20 not compatible with Min/Max v 1.9.2.201"

I realize I should follow the steps as above, but I don't know how. I am 83 and took my second computer class last winter, so I am getting better at this and I realize if I'm going to really learn how to do things, I have to ask questions instead of calling upon a granchild to help.

So how do I download "a fresh file" if I can't get on the net with Firefox?

Exactly which files do I remove?

How to I make sure I "Do not remove personal data when you uninstall the current version"?

I have a 5 year old computer running Windows XP.

I am submitting this question using my grandson's laptop, but I don't want him to do it for me, I want to learn how to do it myself.

I thank you very much for your patience towards an old granny. It is very much appreciated!

I have the same problem. Message says "ERROR, platform version 1.9.2.20 not compatible with Min/Max v 1.9.2.201" I realize I should follow the steps as above, but I don't know how. I am 83 and took my second computer class last winter, so I am getting better at this and I realize if I'm going to really learn how to do things, I have to ask questions instead of calling upon a granchild to help. So how do I download "a fresh file" if I can't get on the net with Firefox? Exactly which files do I remove? How to I make sure I "Do not remove personal data when you uninstall the current version"? I have a 5 year old computer running Windows XP. I am submitting this question using my grandson's laptop, but I don't want him to do it for me, I want to learn how to do it myself. I thank you very much for your patience towards an old granny. It is very much appreciated!
cor-el
  • Top 10 Contributor
  • Moderator
17177 solutions 155254 answers

You can download the latest Firefox 3.6.x version here:

There will be another update shortly (maybe tomorrow) to repair some certificates that were disabled by accident (Firefox 3.6.21 fixed a security issue with a compromised root certificate).

If you choose to uninstall Firefox via the "Control Panel > Add and remove programs" then you see a check box in that uninstall window to remove personal data.
You need to make sure that that box doesn't have a check-mark in it.
You can also first try to only delete the Firefox program folder (C:\Program Files\Mozilla Firefox\) as this issue is likely to be caused by security software that is preventing Firefox from replacing (updating) all the required files.


See also:

You can download the latest Firefox 3.6.x version here: *Firefox 3.6.x: http://www.mozilla.com/en-US/firefox/all-older.html *Firefox 6.0.x: http://www.mozilla.com/en-US/firefox/all.html There will be another update shortly (maybe tomorrow) to repair some certificates that were disabled by accident (Firefox 3.6.21 fixed a security issue with a compromised root certificate). If you choose to uninstall Firefox via the "Control Panel > Add and remove programs" then you see a check box in that uninstall window to remove personal data.<br /> You need to make sure that that box doesn't have a check-mark in it.<br /> You can also first try to only delete the Firefox program folder (C:\Program Files\Mozilla Firefox\) as this issue is likely to be caused by security software that is preventing Firefox from replacing (updating) all the required files. ---- See also: *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Backing_up_and_restoring_bookmarks_-_Firefox
justjo 0 solutions 2 answers

THANK YOU VERY MUCH for your prompt reply! I am going to give it a try. I really appreciate your assistance!

THANK YOU VERY MUCH for your prompt reply! I am going to give it a try. I really appreciate your assistance!