X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 6.0 not compatible with antivirus software

Posted

I updated Firefox to 6.0 and now it said it is not compatible with my antivirus software or ghostery or a lot of other programs. The secure connection lock icon, or ghost icon in ghostery, no longer shows up. I feel like my connection is all of a sudden very UNSECURED. What do I do? Is there a way to go back to my previous version of Firefox? If so, how do I accomplish that?

I updated Firefox to 6.0 and now it said it is not compatible with my antivirus software or ghostery or a lot of other programs. The secure connection lock icon, or ghost icon in ghostery, no longer shows up. I feel like my connection is all of a sudden very UNSECURED. What do I do? Is there a way to go back to my previous version of Firefox? If so, how do I accomplish that?

Additional System Details

This happened

Every time Firefox opened

This started when...

I downloaded Firefox 6.0

Installed Plug-ins

ghostery

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.112 Safari/535.1

More Information

Andrew
  • Moderator
321 solutions 4036 answers

We have 3.6.20 available.

We have 3.6.20 available.