X
Tap here to go to the mobile version of the site.

Support Forum

I just downloaded 6.0 and now my firefox keeps freezing. How can I fix this?

Posted

I downloaded the newest version of Firefox, yesterday, and now it keeps freezing. What can be done about this?


Firefox 6.0 My system is Mac OS X 10.5.8

I downloaded the newest version of Firefox, yesterday, and now it keeps freezing. What can be done about this? Firefox 6.0 My system is Mac OS X 10.5.8

Additional System Details

Installed Plug-ins

  • http://www.facebook.com/fbplugin/
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 4.0.51204.0
  • Version 2.1.7.2968
  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Shockwave Flash 10.2 r152
  • Java Plug-In 2 for NPAPI Browsers

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

k_rock 0 solutions 1 answers

I have this same problem, except I am running a dual-core Windows XP 64-bit system with 4 GB of RAM. I experience random freezes throughout the day where the entire browser will lock up for a minute or two.

I have this same problem, except I am running a dual-core Windows XP 64-bit system with 4 GB of RAM. I experience random freezes throughout the day where the entire browser will lock up for a minute or two.

Modified by k_rock

ccat11 0 solutions 14 answers

I have the same problem with Windows 7, 64bit. Others I kno, too with Win 7 and Vista. Pages hang, freeze, activity indicator doesn't stop spinning. I don't know anyone on Ff 6 who isn't having this problem. See https://support.mozilla.com/en-US/questions/864462[https://support.mozilla.com/en-US/que.../864462]

I have the same problem with Windows 7, 64bit. Others I kno, too with Win 7 and Vista. Pages hang, freeze, activity indicator doesn't stop spinning. I don't know anyone on Ff 6 who isn't having this problem. See https://support.mozilla.com/en-US/questions/864462[[https://support.mozilla.com/en-US/questions/864462]]

Modified by ccat11

Question owner

I cleared the history and it helped a little, but it's been VERY slow and continues to lock up. Very frustrating. Sometimes I use safari at the same time b/c I'm having so much trouble with firefox. I should just ditch firefox, but I've been using it for so long and have all my favorite sites saved here.  ;(

I cleared the history and it helped a little, but it's been VERY slow and continues to lock up. Very frustrating. Sometimes I use safari at the same time b/c I'm having so much trouble with firefox. I should just ditch firefox, but I've been using it for so long and have all my favorite sites saved here. ;(
Stuart_B 0 solutions 1 answers

Helpful Reply

I'm using FF 6 as well and a week ago the message kept coming up to say it wasn't responding when you clicked to go to a link or another page and the mouse pointer just changed to the hourglass and did nothing and if you clicked the mouse again the screen went a bit greyed over ...a half a minute or so later it came back to life ..At first I thought it was the mouse so tried 2 others but it kept happening and FF was unuseable .I disabled all the add-ons and cleared the cache ....no difference so I have changed to Google Chrome ..Mozilla def needs to get a fix for this .

I'm using FF 6 as well and a week ago the message kept coming up to say it wasn't responding when you clicked to go to a link or another page and the mouse pointer just changed to the hourglass and did nothing and if you clicked the mouse again the screen went a bit greyed over ...a half a minute or so later it came back to life ..At first I thought it was the mouse so tried 2 others but it kept happening and FF was unuseable .I disabled all the add-ons and cleared the cache ....no difference so I have changed to Google Chrome ..Mozilla def needs to get a fix for this .
JamesJ 0 solutions 19 answers

For what it's worth, I installed Firefox a couple days ago and I haven't seen any problems at all. I have a Windows 7 Home Premium system with 6gb of ram.

For what it's worth, I installed Firefox a couple days ago and I haven't seen any problems at all. I have a Windows 7 Home Premium system with 6gb of ram.
cglupker 0 solutions 4 answers

Helpful Reply

Same issue. Freezes on youtube, flash, etc. I think Firefox is turning into IE. Bogged down and slow. I run chrome and zero issues with the same sites.

Too bad since Firefox use to be the best browser out there. It's falling quickly.

Same issue. Freezes on youtube, flash, etc. I think Firefox is turning into IE. Bogged down and slow. I run chrome and zero issues with the same sites. Too bad since Firefox use to be the best browser out there. It's falling quickly.
foralien 0 solutions 1 answers

I've experiensed the same problem with FF6 on Mac OS X 10.5 after updrage from FF5. As far as I can see the most common case of this "freezing" occurs after right-click on link of some input field... It annoyed me madly and I'm considering the reinstallation of previous version...

Does somebody know if there is any fix for that?

I've experiensed the same problem with FF6 on Mac OS X 10.5 after updrage from FF5. As far as I can see the most common case of this "freezing" occurs after right-click on link of some input field... It annoyed me madly and I'm considering the reinstallation of previous version... Does somebody know if there is any fix for that?
JimGrady 0 solutions 6 answers

I have raised the same problem!

I have raised the same problem!
hamvestor 0 solutions 1 answers

I am having the same problem. It started several weeks ago. I get the hour glass and FF (6.0) freezes up. Using Windows 7, 64-bit. I'm having no similar problems on IE or Chrome, but I would prefer to use FF if this very annoying problem can be resolved!

I am having the same problem. It started several weeks ago. I get the hour glass and FF (6.0) freezes up. Using Windows 7, 64-bit. I'm having no similar problems on IE or Chrome, but I would prefer to use FF if this very annoying problem can be resolved!
sha66y 0 solutions 1 answers

Same here. Mac 10.5.8 - 'not responding' several times a day since the upgrade. Use FF mainly for development because I need the plugins - looking for alternatives and welcoming suggestions.

Same here. Mac 10.5.8 - 'not responding' several times a day since the upgrade. Use FF mainly for development because I need the plugins - looking for alternatives and welcoming suggestions.

Question owner

I am also having difficulties with sending attachments and images on my emails. Will not send and will not place images on email. I use AOL. I use safari with AOL, and it's fine. So not sure where to report this. Hopefully they read there message boards.

I am also having difficulties with sending attachments and images on my emails. Will not send and will not place images on email. I use AOL. I use safari with AOL, and it's fine. So not sure where to report this. Hopefully they read there message boards.
Muthafodder 1 solutions 10 answers

Solution I've toyed with that worked for me: I turned off "Hardware Acceleration When Available" under Firefox --> Options --> Options --> Advanced Tab --> General Tab

I also disabled the following Plugins under Firefox --> Add-ons --> Plugins: Microsoft Office 2010 Plugins (2 and may be Office 2007 etc. for others); Silverlight; Windows Live Photo Gallery

I then right clicked the Firefox icon on the taskbar and unpinned it. Went to "C:\Program Files (x86)\Mozilla Firefox" folder and turned on "run as administrator" by right clicking the application icon and selecting properties --> compatibility tab --> run this program as an administrator check box...apply settings...click OK. Then right click the icon again and pin it back to the task-bar. You'll get an annoying pop-up from Windows about approvals...follow the prompts and disable these warnings.

I didn't clear the cache as I wanted to verify the potential fix with these changes I had performed...but I did restart Firefox...seems MUCH faster now...not sure if either/or of the solutions I provided fixed the issue for me.

I also noticed that the navigation of the Firefox icon within the All Programs link under the Start/Windows Icon in the bottom left changed from the "C:\Users\xxx\AppData\Roaming\Microsoft\Windows\Start Menu\Programs" folder to the actual location of Firefox "C:\Program Files (x86)\Mozilla Firefox" folder...sneaky bastards. Not sure if this was due to a Microsoft update or their sly means of tracking Firefox users...but I'll be sure to keep an eye on it.

Seems to no longer hang when scrolling and loads faster on forums...for now, but the problem seemed to exasperate the longer an instance of Firefox ran before the solution above...I'll update again with thoughts on this being resolved. For now, it seems to be the same Firefox I fell in love with :)


Other Solution to annoying problem regarding the two instances of Firefox in the taskbar after updating from several versions ago:

After you click on Firefox in the taskbar and a new instance appears, right-click on the original instance and select unpin from the taskbar, then right-click on the instance still open (the second instance) and pin to taskbar. Close Firefox and click on the icon in the taskbar and smile at the results :) This may be required after updating Firefox each time...dunno.

Solution I've toyed with that worked for me: I turned off "Hardware Acceleration When Available" under Firefox --> Options --> Options --> Advanced Tab --> General Tab I also disabled the following Plugins under Firefox --> Add-ons --> Plugins: Microsoft Office 2010 Plugins (2 and may be Office 2007 etc. for others); Silverlight; Windows Live Photo Gallery I then right clicked the Firefox icon on the taskbar and unpinned it. Went to "C:\Program Files (x86)\Mozilla Firefox" folder and turned on "run as administrator" by right clicking the application icon and selecting properties --> compatibility tab --> run this program as an administrator check box...apply settings...click OK. Then right click the icon again and pin it back to the task-bar. You'll get an annoying pop-up from Windows about approvals...follow the prompts and disable these warnings. I didn't clear the cache as I wanted to verify the potential fix with these changes I had performed...but I did restart Firefox...seems MUCH faster now...not sure if either/or of the solutions I provided fixed the issue for me. I also noticed that the navigation of the Firefox icon within the All Programs link under the Start/Windows Icon in the bottom left changed from the "C:\Users\xxx\AppData\Roaming\Microsoft\Windows\Start Menu\Programs" folder to the actual location of Firefox "C:\Program Files (x86)\Mozilla Firefox" folder...sneaky bastards. Not sure if this was due to a Microsoft update or their sly means of tracking Firefox users...but I'll be sure to keep an eye on it. Seems to no longer hang when scrolling and loads faster on forums...for now, but the problem seemed to exasperate the longer an instance of Firefox ran before the solution above...I'll update again with thoughts on this being resolved. For now, it seems to be the same Firefox I fell in love with :) Other Solution to annoying problem regarding the two instances of Firefox in the taskbar after updating from several versions ago: After you click on Firefox in the taskbar and a new instance appears, right-click on the original instance and select unpin from the taskbar, then right-click on the instance still open (the second instance) and pin to taskbar. Close Firefox and click on the icon in the taskbar and smile at the results :) This may be required after updating Firefox each time...dunno.

Modified by Muthafodder

Hotarubichen 0 solutions 1 answers

>>I also disabled the following Plugins under Firefox --> Add-ons --> Plugins: >Microsoft Office 2010 Plugins (2 and may be Office 2007 etc. for others); >Silverlight; Windows Live Photo Gallery

>Fixed it for me. Thanks.

Edited to add:

An overnight update has hosed it again. Patience is thin.

>>I also disabled the following Plugins under Firefox --> Add-ons --> Plugins: >Microsoft Office 2010 Plugins (2 and may be Office 2007 etc. for others); >Silverlight; Windows Live Photo Gallery >Fixed it for me. Thanks. Edited to add: An overnight update has hosed it again. Patience is thin.

Modified by Hotarubichen

Question owner

You are using Windows PC, correct? I am having a problem finding Plug-ins and add-ons, using my iMac. I did disable "Hardware Acceleration When Available", which was under Preferences(for MACs), not Option..;)

You are using Windows PC, correct? I am having a problem finding Plug-ins and add-ons, using my iMac. I did disable "Hardware Acceleration When Available", which was under Preferences(for MACs), not Option..;)
Muthafodder 1 solutions 10 answers

Here's a pic of the related Windows add-on location. I know it's not MAC, but the Firefox browsers should be similar with the same icons.

If you find it, disable any extensions that you don't remember allowing...e.g Microsoft, Apple, etc.

Here's a pic of the related Windows add-on location. I know it's not MAC, but the Firefox browsers should be similar with the same icons. If you find it, disable any extensions that you don't remember allowing...e.g Microsoft, Apple, etc.

Question owner

OK...I did find this. Wasn't sure if this was what you were talking about. Now the problem is, I don't know what I need. Don't know what Silverlight plugin is for. I am afraid to disable things I need, especially what I don't know what they are for..;) Thank you for all your help, including the attachment! =)

OK...I did find this. Wasn't sure if this was what you were talking about. Now the problem is, I don't know what I need. Don't know what Silverlight plugin is for. I am afraid to disable things I need, especially what I don't know what they are for..;) Thank you for all your help, including the attachment! =)
ccat11 0 solutions 14 answers

Updated to 6.0.1 a few days ago and hanging, pages not loading even worse. Has crashed about 20 times, always when loading a new tab, and often on pages with flash. Also put a blank icon next to Ff icon in quick launch bar. If I try to unpin it, the regular Ff icon disappears, too. It just keeps getting worse.

Updated to 6.0.1 a few days ago and hanging, pages not loading even worse. Has crashed about 20 times, always when loading a new tab, and often on pages with flash. Also put a blank icon next to Ff icon in quick launch bar. If I try to unpin it, the regular Ff icon disappears, too. It just keeps getting worse.
psybases 0 solutions 2 answers

Try to create a new profile and import only the password files from the old profile.

Try to create a new profile and import only the password files from the old profile.
jeff69 0 solutions 1 answers

I am having the same prob with freezing in Firefox 6.0.2. If they cant get this fixed I will just go back to chrome. I like Firefox but they seem to be dropping the ball and doing nothing about it but blaming flash. Everything is updated so don't waist my time telling me to do so.I installed and reinstalled everything the only consistent thing is Firefox. I tried to downgrade Firefox but when I do it just re updates its self I think I should be allowed to choose if I want it to update or not. Is there a way to stop it from upgrading and why send out an upgrade if its having so many problems?

I am having the same prob with freezing in Firefox 6.0.2. If they cant get this fixed I will just go back to chrome. I like Firefox but they seem to be dropping the ball and doing nothing about it but blaming flash. Everything is updated so don't waist my time telling me to do so.I installed and reinstalled everything the only consistent thing is Firefox. I tried to downgrade Firefox but when I do it just re updates its self I think I should be allowed to choose if I want it to update or not. Is there a way to stop it from upgrading and why send out an upgrade if its having so many problems?
H2O2 0 solutions 1 answers

I'm using Firefox 6.0.2 on Windows 7 Professional. The only freezing I had was when I would search on Google. Yahoo search worked but was slow. I did what a previous post suggested and disabled Word, Silverlight, and Windows Photo Gallery plugins. I also uninstalled a social addon (forgot the name) for Facebook. The addon was installed by an app on Facebook I think. Google runs smooth now. No freezing. I'm thinking that social addon was the cause to my problem though. I'm gonna try enabling the plugins one at a time to see is they work.

I'm using Firefox 6.0.2 on Windows 7 Professional. The only freezing I had was when I would search on Google. Yahoo search worked but was slow. I did what a previous post suggested and disabled Word, Silverlight, and Windows Photo Gallery plugins. I also uninstalled a social addon (forgot the name) for Facebook. The addon was installed by an app on Facebook I think. Google runs smooth now. No freezing. I'm thinking that social addon was the cause to my problem though. I'm gonna try enabling the plugins one at a time to see is they work.