X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Add On for Orbit Downloader is not working after update to Firefox 6.0. It was working in the last version.

Posted

I have updated to Firefox 6.0 and Orbit Downloader Plugin is not working.

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • Shockwave Flash 10.3 r183
  • GEPlugin
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Get an update for Orbit.

Helpful Reply

I am using latest version of Orbit Downloader and its doesn't have update anymore. However I have reverted to Firefox 4.0 to let Orbit Downloader work for me. A suggestion for Firefox Admins, ' Whenever new version is launched, please ensure it supports all previous add on and extensions'. Thanks

Modified by Qaisar

seybernetx 0 solutions 30 answers

Get an update for Orbit.

Anyone want to know why more and more people are giving up on Firefox?

Firefox deliberately breaks the interface to Orbit, and it is Orbit's fault.

sigh....

PS: It looks like the last change from Orbit was just to track another interface change from Firefox V:5. (I didn't realize Google saw Orbit as a competitor) (or is it Microsoft?)

seybernetx 0 solutions 30 answers

Helpful Reply

Forgot what I originally wanted to post.

Just for the record, Firefox V:8 and Orbit don't play together, either.

I would start a separate thread for that if I thought anyone would actually try to fix the problem, but it is clear Firefox is doing this on purpose, for some reason.

pabloinme 0 solutions 1 answers

I've tried reverting back to an earlier version of Firefox and still could no longer use Orbit downloader or Grabb++, and at the same time the older version would not allow me to use Plain Old Favorites. I have now re-upgraded back to Firefox 10.

Modified by pabloinme