X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When opening a new tab, babylon search opens by default (which I Hate), How can I change it?

Posted

Babylon search and tool bar, got installed in my computer when I installed some other program (Ares). And now there is no way I can get rid of it (of Babylon). Please help. It is annoying.

Additional System Details

This happened

Every time Firefox opened

This started when...

I downloaded Ares

Installed Plug-ins

  • nphpclipbook
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • GEPlugin
  • 3.0.40818.0
  • MSN® Toolbar
  • Google Update
  • Adobe Acrobat Plug-In Version 5.00 for Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

Everytime I open a new tab, automatically opens:
http://search.babylon.com/?babsrc=NT_bb

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

See:

alemo 0 solutions 1 answers

Helpful Reply

hi, go firefox menu bar and then to tools/ add-ons/ extensions and remove babylon toolbar I did it and worked for me ! Good luck!

Question owner

Thanks for your help! Problem solved...

NoMoreBabylon 0 solutions 2 answers

Uninstall Babylon Toolbar - Mozilla Firefox:

1. Click the "Tools" menu in the Firefox browser.

2. Click the "Add-ons" menu item.

3. In the “Extensions Manager” window scroll until you find the “Babylon Toolbar” extension.

4. Click the “Babylon Toolbar” extension.

5. Click "Uninstall".

6. Click “Uninstall" in the "Babylon Toolbar" window.

7. Exit Extensions Manager and restart your browser.

almostmroz 0 solutions 1 answers

That'd be great... IF i could LOCATE my firefox tool bar! That's gone too!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that you do not run Firefox in Full Screen mode with all toolbars hidden.

  • Press F11 to toggle full screen mode (Firefox/File > Full Screen)

If the menu bar is hidden then press the F10 key or hold down the Alt key, that should make the menu bar appear.

  • Go to "View > Toolbars" and check-mark the toolbars that you want to make visible with a click on that entry.
jcdrisc 0 solutions 1 answers

to restore GOOGLE in the toolbar BABYLON must be completely removed. I am running WIN7 home edition and I had to use REGEDIT.

The use of ADD/REMOVE PROGRAMS is not enough.

caruai 0 solutions 1 answers

Yep did the same thing.. Just follow the steps below:

> Go to Tools > Add - Ons > Disable Babylon.

Worked like a charm!

cnapsa2 0 solutions 1 answers

hey people i have a solution to the problem of to the babylon jerk, > Go to Tools > Add - Ons > Disable Babylon. (Restart Mozilla Firefox)

steepturn 0 solutions 1 answers

Helpful Reply

It does not work, because "babylon" is not listed in my Add-Ons. Sorry