X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Windows 7 cleartype NOT working with Firefox 6 (it worked with Firefox 5)

Posted

As soon as I upgraded to Firefox 6 on Aug 16, 2011 - the Windows 7 cleartype stopped working within firefox.

The text now looks blurry and light. I disabled all addons, tried safe mode. It was always the same thing.

To fix this, I manually downgraded to Firefox 5. As soon as I did this, the cleartype was back. The text was dark, the way it always was.

I have the same addons with both versions and I've tried to repeatedly install both versions, but with the same end result. Windows Cleartype doesn't seem to work in Firefox 6 (compared to Firefox 5).

Firefox 6 is amazing, but non-compatibility with Windows7 cleartype is a big issue. One of the best features of firefox is the tinkering it allows with it's fonts, and the clarity of text it allows. Sadly this doesn't work in Firefox 6.

I've downgraded to Firefox 5 for now. Hopefully this will be resolved soon..

Modified by imjimmy

Additional System Details

This happened

Every time Firefox opened

This started when...

Upgrade to Firefox 6.0

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Version 2.1.8.0
  • np-mswmp
  • Winamp Application Detector
  • Google Update
  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.


Question owner

Thanks for the response. I have the latest graphics card driver on my windows 7 x64 PC. I tried disablng hardware acceleration, but no improvement. Everything is the same.

That is, the text is still without cleartype on Firefox 6. It's light and slightly blurry.

After this I downgraded again from 6.0 to 5.0, and immediately the text looks excellent. It's clear, dark and very easy to read.

This is the first time I've had a problem with a firefox upgrade w.r.t cleartype..

Modified by imjimmy

Üllar 0 solutions 3 answers

Helpful Reply

I had the exact same issue after updating. I even resorted to downgrading yesterday after not finding any decent work-around for this, but when it forced an update today upon starting Firefox I just had to clear this up. Here's what you can do:


  1. Type about:config in the address bar.
  1. Type gfx.font into the filter bar.
  1. Focus on the following parameters: cleartype_level, enhanced_contrast, gamma, pixel_structure and rendering_mode. Forget about the rest.
  1. Press Start and type regedit into the search field.
  1. Once there, choose the following: HKEY_CURRENT_USER - Software - Microsoft - Avalon.Graphics - DISPLAY1 and note down each value represented in the data column within the brackets. For example, my ClearTypeLevel value is 100, EnhancedContrastLevel is 400 and TextContrastLevel is 2.
  1. Now that you've found these values, go back to the configuration in Firefox and right click on the cleartype_level parameter, and choose Modify. Now enter that very same value from before (100, for me) in there. Do that with the rest of the values. I put my rendering_mode as 2, which could coincide with the TextContrastLevel, but it might not, but the rendering_mode values range from -1 to 5, so see which works for you.
  1. To change the gamma and pixel_structure, go back to the Registry Editor like before, but this time follow this: HKEY_LOCAL_MACHINE - SOFTWARE - Microsoft - Avalon.Graphics - DISPLAY1 and note the values within the brackets from there.
  1. Replace those values to the ones in the configuration and you're all set!

If you want to read more about those configuration parameters and their values, here's a great article of sorts about it. It's about Thunderbird 6.0, but everything mentioned there correlates with Firefox 6.0.

This is as close as I've gotten to the text looking like it's supposed to and if even this doesn't work for you then I'm open to any and all suggestions anyone might have : /

Modified by Üllar

Question owner

Thanks for this. Unfortunately this did NOT help. I replaced all the values in gfx.font, by looking at the registry. Following are the things I changed --

gfx.font_rendering.cleartype_params.cleartype_level;100

gfx.font_rendering.cleartype_params.enhanced_contrast;400

gfx.font_rendering.cleartype_params.gamma;2200

gfx.font_rendering.cleartype_params.pixel_structure;1

gfx.font_rendering.cleartype_params.rendering_mode;2

__________

NO DIFFERENCE. I reinstalled Firefox 5 and that is clear as a daisy..

This is unfortunate. I have no idea what the Firefox developers changed in Firefox 6, so that cleartype is not supported anymore..

Üllar 0 solutions 3 answers

That is so odd. I have the same exact settings except I changed my rendering_mode to 0 after tinkering with the settings. Right now, everything seems as it should be for me, like it was with Firefox 5.

To my understanding, they changed the overall text's rendering to allow more customization. If you look at the configuration in Firefox 5, you'll see that it has far less options to customize the text, but this is just conjecture. I really hope someone comes up with a more universal fix for this.

Nathan_V 0 solutions 1 answers

Thank you, been0x!!! Your post is very, very clear and helpful!

Question owner

FINALLY thanks to been0x for the reply.

Following are the settings in about:Config which worked for me. This is the closest to Firefox 5 in terms of clear type text (IMO).

gfx.font_rendering.cleartype_params.cleartype_level;100

gfx.font_rendering.cleartype_params.enhanced_contrast; 700 ( the enhanced contrast value is the one to be tinkered with. Higher setting results in more contrast and darker text. Many people might prefer values between 400 to 1000).

gfx.font_rendering.cleartype_params.gamma;2200

gfx.font_rendering.cleartype_params.pixel_structure;1

gfx.font_rendering.cleartype_params.rendering_mode; 0 ( 0 is important as this is the default handling)

Modified by imjimmy