Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am gettng the following popup when using firfox as my browser: Exc in ev handl: Error: Bad NPObject as private data!

  • 17 replies
  • 3931 have this problem
  • 1642 views
  • Last reply by AliceWyman

more options

In the past few days I have been getting the following popup when I use firefox as my browser: Exc in ev handl: Error: Bad NPObject as private data!

I assume it came from your latest update. I have windows vista with a 64 bit processor, and I am using the latest version of firefox. I checked to see if I was getting the same error message with explorer and I am not. It appears to be some sort of conflict with java script. Can this be corrected?

Chosen solution

You don't have to remove and re-install anything. I had the same problem and simply disabled the McAfee Siteadvisor add-on without removing it. I then restarted Firefox and the problem was solved.

But here's the important part: I then re-enabled the add-on and re-started Firefox a second time. The problem did not return!

So simply disable, re-start, re-enable, and re-start. It worked for me!

Read this answer in context 👍 72

All Replies (17)

more options

Modified by Hasan

more options

If it helps the developers, I can let you know that this problem of "Exc in ev handl: Error: Bad NPObject as private data!" popping up whenever I go to a new web page, started IMMEDIATELY after I installed the latest version of VLC Media PLayer (vlc-1.1.11-win32.exe) and ticked the box, offered during installation, allowing it as a plug-in for Mozilla.

I have no technical expertise, but the link was clear and instant. If it helps, I opened Firefox AFTER I installed the new VLC version. I can't say if it's the new version, or simply the aspect of ticking the Mozilla plug-in that caused it. I have a feeling I did not tick this box when I installed the earlier version, so it's a bit difficult to know if it's the plugin aspect, or the new version of VLC as a whole.

I am running Firefox 6.0 on Windows 7 64-Bit.

I hope this of of some use to someone.

more options

Further to the above. I have just uninstalled VLC MEDIA PLAYER and the problem has gone away. I am receiving no more pop-ups. Later, I will reinstall the latest VLC version but leave the Mozilla box un-ticked, and see if that causes the problem to recur.

more options

FINALLY - I uninstalled VLC Media Player (vlc-1.1.11-win32.exe) entirely, from the Windows Control Panel Uninstaller. I then re-installed the same version of the player. During the fresh installation, it asks you which plugins you want. There is a long list of boxes, all of which are already ticked EXCEPT the "Mozilla Plugin" which is initially un-ticked, and you have to tick it if you want it. This time round, I left the box un-ticked (i.e. no Mozilla Plugin wanted) and finished the installation. VLC now works perfectly well. Firefox also works completely well. The pop-ups have disappeared. So, in my ignorance, the immediate cause (for me) was the Mozilla Plugin in VLC player. If I accepted the plugin, I got the pop-ups. If I didn't accept, then VLC installed fine (as before) but the pop-ups in Firefox stop. Wish I could help with an explanation, but I hope it helps some people. Thanks Martin

more options

re: recommendation -- "Remove McAfee Site Advisor and other extensions/plugins reported in the following lists of Blocked/Problematic extension: "

NO -- I use it to protect my surfing! Why must FireFox insist on constantly breaking 3-rd party vendor apps!?! Even IE doesn't do this.

For all the ballyhoo about FF and how great it is -- it ISN'T when it comes to how it supports other companies apps. (RealPlayer, Google, McAfee, etc.)

Shame on them. I shouldn't have to give up functionality, and in this case protection -- just to use FF

more options

@renmandfx - Its the Third-party Add-ons Vendor's choice or responsibility whether they want to support Firefox with their extensions' updated versions to become compatible with newer Firefox releases. The McAfee Developers have been saying since March that they will release an updated version of AcAfee Site Advisor in the last 3-4 months. Since August, they said that they are completely changing the code of McAfee Site Advisor that will be compatible for a long time with many new Firefox versions and its expected to be released in mid-late September.

Firefox's built-in Safe Browsing covers the major items included in those other Security toolbars:

-> Phishing and Malware Protection

-> Sample warning screens:

-> Browse with Security

Check and tell if its working.

There are many other Security Extensions you can try:

Modified by Hasan

more options

Try restarting Firefox. If that doesn't work.

Disable (again) "McAfee Site Advisor" extension which was just updated to 3.4.0

  • "Ctrl+Shift+A" > find McAfee Site Advisor and use "Disable", and then restart Firefox.
  • Do a Google Search no problem
  • It seems that if you re-enable Site Advisor again, and restart Firefox you are okay.

Best solution appears to be to uninstall Site Advisor and then to reinstall again from www.siteadvisor.com as noted in https://community.mcafee.com/message/203466

Also refer to http://kb.mozillazine.org/Problematic_extensions relating to McAfee Site Advisor 3.4.0

Modified by David McRitchie

more options

Chosen Solution

You don't have to remove and re-install anything. I had the same problem and simply disabled the McAfee Siteadvisor add-on without removing it. I then restarted Firefox and the problem was solved.

But here's the important part: I then re-enabled the add-on and re-started Firefox a second time. The problem did not return!

So simply disable, re-start, re-enable, and re-start. It worked for me!

more options

Mine just started showing this error message today. The only change that was made was an auto update to an extension called "read it later" I removed this from FireFox 6 and it stopped right away. It is clearly a compatibility issue.

Hope this helps!!

more options

In response to MartDL "FINALLY" post:

This was very helpful. I decided to try it. But instead of using the Windows uninstaller I was going to first try the VLC uninstaller. When I went to the VideoLAN start link, an uninstaller was not present; but there was a "Reset VLC media player preferences and cache files" option.

I tried that option and my problems immediately disappered - no more annoying pop-up window error.

Thanks for the help.

Modified by jmlepore

more options

I tried all the suggestions and almost all resulted in the popup going away. Then it returned after a couple days. It does appear to be a compatibility issue. Firefox is my favorite browser however I just switched to chrome until this is fixed which I have no doubt will be.

more options

My problem started with the Site Adviser update in Sept. Prior to that Firefox was flawless. Hopefully McAfee will fix this so I can return to Firefox. My McAfee subscription runs out in Jan and it looks like I need to reevaluate the software.

more options

I had the same problem.. upon Googling found this thread and dissabled all McAfee plugins/extensions and the error was gone!

Lets wait for some updates regarding the plugins and i guess it will be fine then.. till then just dissable your plugins!

more options

Disabling site adviser stopped the popup but when I restated it after the reboot is came back

more options

I did get this error, but then my boyfriend disabled and uninstalled McAfee and emptied out all the caches, cookies and whatever needed to be done and now this is has gone away completely. He also installed Avast! anti-virus and now my computer is not only safer, but it also performs better. McAfee is a joke and should be taken off the market before this causes problems for someone else; especially for those that use their computer for school or work. Thank God, it was very annoying

more options

This may sound incredibly simple. I just restarted my computer and the problem went away. For now any how.

more options

Since the thread has been marked as "solved", I'm locking this thread. If anyone has other questions please start a new thread.