X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't get rid of somoto toolbar search and default homepage. Somoto doesnt appear in the list of searching and also not as installed software in my computer.

Posted

I can't get rid of somoto as default homepage. Somoto doesnt appear in the list of searching and also not as installed software in my computer or as addons of firefox

Chosen solution

-> click Firefox button and click Exit

-> Start Firefox in Safe Mode (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

https://support.mozilla.com/kb/Safe+Mode

Firefox Safe Mode window will open. DON'T SELECT ANY OPTIONS, just click Continue in Safe Mode

Is the Somoto toolbar listed in Add-ons or Plugins sections in Add-ons Manager window while you are running Firefox in Safe Mode ?? If you do see it, Remove it:

https://support.mozilla.com/en-US/kb/Uninstalling%20add-ons

https://support.mozilla.com/en-US/kb/Cannot%20uninstall%20an%20add-on#w_uninstalling-manually

https://support.mozilla.com/en-US/kb/Troubleshooting%20plugins#w_manually-uninstalling-a-plugin

Check and tell if its working.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 10.0 r12
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Xircal 334 solutions 3835 answers

Helpful Reply

Please do the following.

  1. In the location bar where you normally type in a web address, type about:config and hit Enter.

  2. If you see a window which says "This might void your warranty!", click the button which says "I'll be careful, I promise" so you can continue with the next step.

  3. In the filter at the top, type: keyword.URL

  4. Double click it and remove whatever's in there and replace it with http://www.google.com/search?q= and then click OK.

  5. Close the tab

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

Question owner

I followed the instructions, unluckily SOMOTO is still there if i open a new tab...

Question owner

I explain better: I do get Google as start page, but if i open a new tab somoto comes up and i cant find a way to get rid of it Thanks for any help!

Question owner

also if i reset all the somoto stuff in about:config and restart it is still there, the strings go back by themselves to the values i just erased!

Xircal 334 solutions 3835 answers

Helpful Reply

OK, in about:config, type just somoto in the filter. Then for every instance that a value appears in the list with that name, right click it and choose "Reset" from the menu. This will return them to defaults.

Then close Firefox and restart it again to delete them.

Also, click the orange Firefox button, go to Add-ons, then Extensions. If you see Somoto Toolbar in there, remove it.

Question owner

thanks! But in the meanwhile i had already tried resetting all the somoto istances in abou:config and restarted firefox, it didnt help. Moreover somoto doesn't appear in my addons list. Any other idea and help is appreciated

Xircal 334 solutions 3835 answers

Please go to the Firefox Add-ons / Extensions menu and see if you can see an Add-on called "MyStart". Remove if found.

In the Search Bar on the right (the small one), click the down arrow inside it, then at the bottom, click Manage search engines. In the next menu, find "Search The Web". Click it to select, then click "Remove".

Modified by Xircal

Hasan 477 solutions 5600 answers

Chosen Solution

-> click Firefox button and click Exit

-> Start Firefox in Safe Mode (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

https://support.mozilla.com/kb/Safe+Mode

Firefox Safe Mode window will open. DON'T SELECT ANY OPTIONS, just click Continue in Safe Mode

Is the Somoto toolbar listed in Add-ons or Plugins sections in Add-ons Manager window while you are running Firefox in Safe Mode ?? If you do see it, Remove it:

https://support.mozilla.com/en-US/kb/Uninstalling%20add-ons

https://support.mozilla.com/en-US/kb/Cannot%20uninstall%20an%20add-on#w_uninstalling-manually

https://support.mozilla.com/en-US/kb/Troubleshooting%20plugins#w_manually-uninstalling-a-plugin

Check and tell if its working.

Xircal 334 solutions 3835 answers

@ mha007, PLEASE CHECK YOUR INBOX.

Question owner

it seems that the manual download you linked didt the trick https://support.mozilla.com/en-US/kb/Cannot%20uninstall%20an%20add-on#w_uninstalling-manually

thanks!

Question owner

this advice helped too, regarding the search bar thx!

Hasan 477 solutions 5600 answers

@Xircal check your inbox

scooterhead 0 solutions 1 answers

@mha

I can't see anything called " Somoto ....." add-on or plugin when I am in safe mode....

I only get the Somoto search page when I make a new tab -I do not have a Somoto toolbar.

Hasan 477 solutions 5600 answers

@scooterhead Ask your own Question in a New Thread with your Problem Explanation and your System Details

Modified by Hasan

jtonky 0 solutions 1 answers

Hi i found the solution, im firefox 6 i went into regedit and searched for somonto, found a key called somonto toolbar in it had a link http://www.bigseekpro.com/uninstall_complete/solidyoutube Note the solidyoutube went to Firefox add-ons manager and into Extensions, removed Solid youTube Downloader and Converter DB Toolbar 1.1.8. asked me to restart firefox. Problem Solved

Recommend Firefox ban these people!

Julysuu 0 solutions 10 answers

How to Get Rid of Somoto Toolbar and Somoto Homepage Completely

Reference: http://blog.teesupport.com/how-to-uninstall-somoto-toolbar-manually-remove-somoto-com-search-homepage-manually/

1. Go to Control Panel and uninstall Somoto Toolbar from Add/Remove Programs list.

2. Remove Somoto Toolbar add-on from your browsers. For example, on Internet Explorer, click on "Tools" and choose "Manage Add-ons", click "Add-ons and Extensions", and then remove Somoto Toolbar from the list. On FireFox, click on "Tools" and choose "Add-ons", click "extentions" and then remove "Somoto Toolbar".

3. If Somoto Toolbar still appears, check the following directories and remove Somoto Toolbar associated files:

C:\Program Files\Somoto Toolbar C:\Documents and Settings\[user name]\Local Settings\Temporary Internet Files\[you can clear the whole folder] C:\Documents and Settings\[user name]\Local Settings\Temp\[you can clear the whole folder]

4.The registry entries of Somoto Toolbar that need to be removed are listed as follows:

HKEY_LOCAL_MACHINE\SOFTWARE\Somoto Toolbar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Somoto Toolbar


5. Launch your browser, click "Tools" on the menu bar, choose "Internet Options" and then clear internet history records, internet temp files and cookies, reset homepage.

6. Restart your browser, Somoto Toolbar and somoto.com search will be gone.

tinkaloca 0 solutions 1 answers

heres something that worked for me.. get rid of REAL player and the youtube video download program (which i think comes along with the REAL player program), if you have it.

go to control panel > uninstall programs > then uninstal both of em [if u have it].

then it will require to to reboot your computer and wen it restarts....

POOOF! its gone...

ive always thought that the real player had something fishy in it...

i mean downloading videos is kool... but the fact that everytime i open a new tab with friggin somata page poppin up annoys me more than the kool REAL program.

soo bye REAL!

ps: im not sure if that is the cause of it, but it worked for me.. so if u wanna keep ur real player and the youtube downloader? then good luck! xoxo

Doug47 0 solutions 1 answers

Xircal's solutions worked for me. The problem went away. Thank you! Doug47

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

If the answers given above don't work for you, see the Fix problems with your home page or search article for other suggestions or else start a new thread, using this link as a starting point: https://support.mozilla.org/en-US/questions/new

The owner of this thread reported that his problem was solved so this thread is now locked.